Last Comment Bug 561481 - Remove README.txt from release packages
: Remove README.txt from release packages
Status: VERIFIED FIXED
[qa-][testday-20110930]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal with 2 votes (vote)
: Firefox 8
Assigned To: Ed Morley [:emorley]
:
Mentors:
: 361043 565891 674907 (view as bug list)
Depends on: 443112
Blocks: 678979
  Show dependency treegraph
 
Reported: 2010-04-23 15:21 PDT by Christopher Yeleighton
Modified: 2013-10-14 13:16 PDT (History)
15 users (show)
bzbarsky: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove README.txt (4.53 KB, patch)
2011-06-16 12:30 PDT, Ed Morley [:emorley]
no flags Details | Diff | Review
Remove README.txt (4.86 KB, patch)
2011-06-17 10:45 PDT, Ed Morley [:emorley]
no flags Details | Diff | Review
Remove README.txt (45.31 KB, patch)
2011-06-17 10:53 PDT, Ed Morley [:emorley]
dolske: review+
mark.finkle: review+
Details | Diff | Review
Remove README.txt apart from on OS/2 (4.17 KB, patch)
2011-07-09 03:24 PDT, Ed Morley [:emorley]
emorley: review+
Details | Diff | Review

Description Christopher Yeleighton 2010-04-23 15:21:11 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; pl-PL; rv:1.9.1.9) Gecko/20100317 SUSE/3.5.9-0.1.1 Firefox/3.5.9
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; pl-PL; rv:1.9.1.9) Gecko/20100317 SUSE/3.5.9-0.1.1 Firefox/3.5.9

The file README.txt in firefox-3.6.3.tar.bz2 refers to the URL [1] for installation instructions.   However, the resource returned does not contain any installation instructions for Linux.

[1] http://getfirefox.com/releases/

Reproducible: Always

Steps to Reproduce:
1.Download the file firefox-3.6.3.tar.bz2 .
2. Read README.txt .
3. Go to the advertised documentation URL.
Actual Results:  
1. The file is an archive; it contains a file named README.txt .
2. Installation instructions are on page [1].
3. There are no installation instructions for Linux.

Expected Results:  
1. Installation instructions are on page [2].

[2] http://support.mozilla.com/pl/kb/Installing+Firefox+on+Linux
Comment 1 Tyler Downer [:Tyler] 2010-04-23 15:51:48 PDT
Please go to support.mozilla.com for help. Bugzilla is not a support site.
Comment 2 Matthias Versen [:Matti] 2010-04-24 05:55:42 PDT
He didn't ask for support and this bug is valid.
The readme.txt contains a wrong link.There are no installation instructions at that location.
The link [2] can not be used because this is a general file that exists on all platforms
Comment 3 Zibi Braniecki [:gandalf][:zibi] 2011-05-27 13:38:52 PDT
Is it reproducible on Fx 4.0?
Comment 4 Justin Dolske [:Dolske] 2011-05-31 17:15:42 PDT
We should just remove this file, it's not worth keeping up to date.
Comment 5 Henri de Solages 2011-06-13 07:49:44 PDT
@Zbigniew Braniecki: Yes, this problem regards Firefox 4.0.1, whose file README.txt just send the user to http://getfirefox.com/releases , redirected, as far as I'm concerned, to http://www.mozilla.com/en-US/firefox/new/?from=getfirefox
where there is no installation instruction at all.
@Justin Dolske: a README.txt file is useful. The user uncompresses the file. And then, what to do?
Comment 6 Ed Morley [:emorley] 2011-06-16 12:30:25 PDT
Created attachment 539869 [details] [diff] [review]
Remove README.txt

Removes README.txt from releases & adds it to the list of files to be removed by the installer on update. Pretty sure that's everything:
http://mxr.mozilla.org/mozilla-central/search?string=README.txt&case=1&find=&findi=&filter=\bREADME.txt\b&hitlimit=&tree=mozilla-central
Comment 7 Ed Morley [:emorley] 2011-06-17 10:45:05 PDT
Created attachment 540089 [details] [diff] [review]
Remove README.txt

Updated patch
Comment 8 Ed Morley [:emorley] 2011-06-17 10:53:31 PDT
Created attachment 540092 [details] [diff] [review]
Remove README.txt

Third time lucky, found the OS2 variants README.* as well.
Comment 9 Ed Morley [:emorley] 2011-06-17 16:52:17 PDT
http://dev.philringnalda.com/tbpl/?tree=Try&rev=a03554955ed0
Comment 10 Justin Dolske [:Dolske] 2011-06-20 14:31:48 PDT
Comment on attachment 540092 [details] [diff] [review]
Remove README.txt

Looks fine to me. Requesting r? from mfinkle just as a heads-up on the mobile change, and feedback? from Peter Weilbacher for consent on the OS/2 changes. (I would suggest the OS/2 folks move the readme contents to a Wiki page instead, if this content is still useful).
Comment 11 Justin Dolske [:Dolske] 2011-06-20 14:35:04 PDT
(In reply to comment #5)

> @Justin Dolske: a README.txt file is useful. The user uncompresses the file.
> And then, what to do?

If a user doesn't know how to launch Firefox, they're unlikely to know how to find or read the README. Judging from the fact that the link in the README is largely useless anyway, we're not making things any worse. For these confused users, they should ask the friend who suggested Firefox, Google, or support.mozilla.org.
Comment 12 Mark Finkle (:mfinkle) (use needinfo?) 2011-06-20 19:08:28 PDT
Comment on attachment 540092 [details] [diff] [review]
Remove README.txt

r+ for the mobile parts
Comment 13 Christopher Yeleighton 2011-06-21 01:41:16 PDT
(In reply to comment #11)
> (In reply to comment #5)
> 
> > @Justin Dolske: a README.txt file is useful. The user uncompresses the file.
> > And then, what to do?
> 
> If a user doesn't know how to launch Firefox, they're unlikely to know how
> to find or read the README. Judging from the fact that the link in the

I disagree.  README is in the GNU Coding Standard, it is also common for various non-GNU (and nonfree) packages.  Even a Microsoft DriveSpace-compressed FAT volume has a README file in the uncompressed part.

Besides, various archive managers allow reading text files without explicit uncompressing, while few allow running compressed applications.  (This comment does not apply to software distributed as an installer application, but then the installer software often presents an equivalent of the README file first.)
Comment 14 Justin Dolske [:Dolske] 2011-06-22 19:01:08 PDT
I don't think that's relevant here. The Linux .tgz releases are simply a convenience for the small number of people who don't get Firefox through their distro's normal package mechanisms (and long term plan is for us to make actual packages available instead of just a tgz). On other platforms (OS X / Windows), if you can get to the readme you're already smart enough to run it.
Comment 15 Christopher Yeleighton 2011-06-23 03:14:16 PDT
A customer who has a support request with respect to Mozilla Firefox has two ways of proceeding: ask the distribution or ask Mozilla support.  Asking the distribution is unlikely to do any good, and asking Mozilla support requires reproducing the problem in genuine Firefox.  However, the instruction how to launch genuine Firefox [2] is hard to find.  The following text is required: 

<**
The following instructions will install Firefox into your home directory, and only the current user will be able to run it.
Note: The installation file provided by Mozilla in .tar.bz2 format does not contain sources but pre-compiled binary files, therefore you can simply unpack and run them. There is no need to compile the program from source if all the system requirements are met.

    Download Firefox from the Firefox download page to your home directory.
    Open a Terminal and go to your home directory: cd ~
    Extract the contents of the downloaded file:tar xjf firefox-*.tar.bz2
    Close Firefox if it's open.
    To start Firefox, run the firefox script in the firefox folder. 

~/firefox/firefox

Firefox should now start. You can then create an icon on your desktop to run this command. 
**>

Note that giving the URL is not sufficient, since the distributed Firefox can be broken (it is: [Bug openSUSE 679217]).
Comment 16 Justin Dolske [:Dolske] 2011-06-24 18:24:40 PDT
I still don't see how any of that is relevant here.

Neither the URL nor README has changed since we switched to Mercurial in early 2007. In all that time, this is the first bug I've heard of someone noticing that the file is utterly unhelpful. IE, no one is looking at it. Similarly, bug 411638 majorly pruned a README from the source tree that was ridiculously out of date. In the 3 years since, it's never been a problem.

We have nearly half a billion users, if even a tiny percentage of them were trying to use this README we'd have been flooded with reports.
Comment 17 Christopher Yeleighton 2011-06-25 01:36:22 PDT
(In reply to comment #16)
> Neither the URL nor README has changed since we switched to Mercurial in
> early 2007. In all that time, this is the first bug I've heard of someone
> noticing that the file is utterly unhelpful. IE, no one is looking at it.

Ugh, so I am no one.  Thanks, I have always suspected that :-)
Comment 18 Ed Morley [:emorley] 2011-07-02 10:25:45 PDT
Peter, ping for the feedback? please.
Thanks :-)
Comment 19 Ed Morley [:emorley] 2011-07-02 10:26:35 PDT
Peter, ping for the feedback? please.
Thanks :-)

[This time with me remembering to add the CC hehe]
Comment 20 Justin Dolske [:Dolske] 2011-07-05 12:11:32 PDT
It's possible Peter is lost in a warpy haze down in Boca Raton, I think you're fine to land this if he's still missing at the end of the week. ;-)
Comment 21 Peter Weilbacher 2011-07-07 05:24:02 PDT
Sorry, I was out of web access for a while.

I think the reason to remove the generic README.txt is valid but I don't think the OS/2 version of it is as useless. OS/2 maintainers have tried to keep it updated regularly with current URLs and it's a well-used resource by OS/2 users. But I am not involved into the release process any more, so I'll bounce the feedback to Walter, who has been doing OS/2 release packaging for a while.
Comment 22 Justin Dolske [:Dolske] 2011-07-08 12:50:32 PDT
Would moving the content to a wiki page be an acceptable alternative?
Comment 23 Christopher Yeleighton 2011-07-08 15:43:40 PDT
How would you read a wiki page when you cannot start your browser?
Comment 24 Ed Morley [:emorley] 2011-07-08 16:46:33 PDT
The same way that you would have downloaded the Firefox release in the first place... in another browser on that machine or else on a different machine.
Comment 25 Rich Walsh 2011-07-08 17:39:32 PDT
Oddly enough, many OS/2 users actually read our ReadMe - and complain when it's out of date (as it is now).  If the consensus is that the generic readme should be abandoned, so be it.  However, I'd like to leave the OS/2 versions tucked away in wdgt/os2 so we can add them to the list of platform-specific files that get included in our distros.
Comment 26 Christopher Yeleighton 2011-07-09 02:58:59 PDT
(In reply to comment #24)
> The same way that you would have downloaded the Firefox release in the first
> place... in another browser on that machine or else on a different machine.

You cannot read a wiki via FTP and you do not always have a different browser or machine.  Moreover, the fact that you need another browser to learn how to start Firefox makes Firefox depend on the competition, which is lame.
Comment 27 Ed Morley [:emorley] 2011-07-09 03:24:36 PDT
Created attachment 544973 [details] [diff] [review]
Remove README.txt apart from on OS/2

OS/2 changes excluded due to comment 25, carrying forwards r+ since no other changes.
Comment 28 Ed Morley [:emorley] 2011-07-09 03:30:51 PDT
Comment on attachment 544973 [details] [diff] [review]
Remove README.txt apart from on OS/2

Although thinking about it, do the browser/installer/package-manifest.in and browser/installer/removed-files.in changes need to be turned into #ifdef XP_OS2 ? Not sure how the widget/src/os2/Makefile.in install-readme section relates to the standard README.txt and so if it is affected by package-manifest.in/removed-files.in?
Comment 29 Rich Walsh 2011-07-09 06:16:11 PDT
(In reply to comment #28)
> do the browser/installer/package-manifest.in and
> browser/installer/removed-files.in changes need to be turned into #ifdef
> XP_OS2 ?

No - we can rename our files to readme.os2 to avoid a name collision.

> Not sure how the widget/src/os2/Makefile.in install-readme section
> relates to the standard README.txt and so if it is affected by
> package-manifest.in/removed-files.in?

Leave the stuff in widget/src/os2 as-is and proceed with the rest of this patch.  We'll develop a separate patch to get the OS/2 files copied/renamed/packaged.  AFAICT, no new #ifdef XP_OS2's should be needed anywhere.
Comment 30 Ed Morley [:emorley] 2011-07-09 06:23:27 PDT
Comment on attachment 544973 [details] [diff] [review]
Remove README.txt apart from on OS/2

Great, thanks Rich.

Carrying forwards r+ then :-)
Comment 33 Mounir Lamouri (:mounir) 2011-07-12 03:43:27 PDT
Merged:
http://hg.mozilla.org/mozilla-central/rev/7106b35be688
Comment 34 Matthias Versen [:Matti] 2011-07-28 14:39:38 PDT
*** Bug 674907 has been marked as a duplicate of this bug. ***
Comment 35 Marc Jessome[:mjessome] 2011-07-29 07:51:47 PDT
I personally take issue with the "fix" for generic READMEs.

Contrary to what is mentioned in Comment 14, I feel that the Linux tgz packages are actually becoming more relevant along with the move to the rapid-release cycle. Many distributions disable auto-update of Firefox and depending on the package manager, updates to the next FF version may not be automatic since the new version may be a new package in the repo.

As already mentioned, having access to a browser prior to install is not always the case, nor is it a very convenient way for users to be getting install instructions.

I realize that the readme may not have the same necessity on other platforms, but I think that it is imperative on Linux. I would be willing to put in the work to maintain a README or an INSTALL file for the Linux packages that contains information similar to the "Installing outside of a package manager" section on http://support.mozilla.com/en-US/kb/Installing%20Firefox%20on%20Linux
Comment 36 [:Aleksej] 2011-09-30 09:55:08 PDT
Verified that there is no README.txt in 8.0b1 for Linux x86_64  en_US, eo, ru.
Comment 37 Steffen Wilberg 2012-01-14 01:26:09 PST
*** Bug 361043 has been marked as a duplicate of this bug. ***
Comment 38 Cees T. 2012-04-20 06:10:12 PDT
(In reply to Justin Dolske [:Dolske] from comment #16)
> I still don't see how any of that is relevant here.
> 
> Neither the URL nor README has changed since we switched to Mercurial in
> early 2007. In all that time, this is the first bug I've heard of someone
> noticing that the file is utterly unhelpful. IE, no one is looking at it.
> Similarly, bug 411638 majorly pruned a README from the source tree that was
> ridiculously out of date. In the 3 years since, it's never been a problem.
> 
> We have nearly half a billion users, if even a tiny percentage of them were
> trying to use this README we'd have been flooded with reports.

You missed bug 361043, for one.
Comment 39 Carsten Book [:Tomcat] 2012-04-20 06:23:39 PDT
*** Bug 361043 has been marked as a duplicate of this bug. ***
Comment 40 Cees T. 2012-04-20 06:58:30 PDT
*** Bug 361043 has been marked as a duplicate of this bug. ***
Comment 41 Matthias Versen [:Matti] 2013-10-14 13:16:55 PDT
*** Bug 565891 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.