Cursor does not change to a hand over link in a web page




Event Handling
18 years ago
16 years ago


(Reporter: Marc Attinasi, Assigned: David Hyatt)



Windows NT

Firefox Tracking Flags

(Not tracked)


(Whiteboard: [rtm++], URL)


(2 attachments)



18 years ago
Hover over a link in a web page with a recent build and the cursor flickers
between a hand and an arrow, but ends up as an arror. Seen on Trunk and Branch
(even in commercial build 2000101108, from where I am writing this up).

Comment 1

18 years ago
Recent regression. I'm looking over recent changes for likely suspects now.
Maybe nsEventStateManager 1.216? I'll try bakcing that out...
Keywords: regression, rtm

Comment 2

18 years ago
Note that the cursor changes to a hand just fine in the personal toolbar and the
sidebar, just not in the content area.

Comment 3

18 years ago
I backed out Hyatt's change to nsEventStateManager (1.216) and this is fixed.
Assigning to him to fix.
Assignee: joki → hyatt
*** Bug 56094 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
Darnit!  Ok, I guess I'm about ready to give up on this and punt it all back to 
joki now that he's back from vacation.  I can back out my fix, but then basic 
:hover will be broken again.

Comment 6

18 years ago
Created attachment 16833 [details] [diff] [review]
Patch that truly reverts us back to the way things were in PR2.

Comment 7

18 years ago
Oops.  I screwed up the first patch.  Only look at the second patch.

Comment 8

18 years ago
Created attachment 16835 [details] [diff] [review]
Real patch.

Comment 9

18 years ago

Comment 10

18 years ago
r: joki
Can we at least get this checked in on the trunk?  The branch would sure be nice
too -- it's a basic UI feature in web browsers since at least NCSA Mosaic,
probably well earlier...

Comment 12

18 years ago
Yikes!  rtm+  This is the fundamental affordance cue for the primary usage case
in a web browser. Many people only click on stuff that shows the hand, so this
could affect web app usability, and therefore click-through for  I
think this is 'pull-it-off-the-wire' territory.
Priority: P3 → P2
Whiteboard: [rtm+]

Comment 13

18 years ago
*** Bug 56252 has been marked as a duplicate of this bug. ***

Comment 14

18 years ago
Please land this on the trunk asap first.
Please update with status of build (re: regressions?) and renominated for branch
Marking need-info
Whiteboard: [rtm+] → [rtm need info]

Comment 15

18 years ago
What's the holdup? Why hasn't this been landed on the trunk?

Comment 16

18 years ago
Does the patch address the multiple mouseover events for text links issue or is 
that unrelated?

Comment 17

18 years ago
*** Bug 56470 has been marked as a duplicate of this bug. ***


18 years ago
Whiteboard: [rtm need info] → [rtm+ need info]
Target Milestone: --- → M18
*** Bug 56566 has been marked as a duplicate of this bug. ***

Comment 19

18 years ago
*** Bug 56658 has been marked as a duplicate of this bug. ***

Comment 20

18 years ago
Please approve for branch checkin.
Whiteboard: [rtm+ need info] → [rtm+] Fixed on trunk

Comment 21

18 years ago
PDT says rtm++, please land on branch ASAP
Whiteboard: [rtm+] Fixed on trunk → [rtm++] Fixed on trunk

Comment 22

18 years ago
Fixed on branch now too.
Last Resolved: 18 years ago
Resolution: --- → FIXED
Whiteboard: [rtm++] Fixed on trunk → [rtm++]

Comment 23

18 years ago
VERIFIED on Mac 10-18-08, NT 10-18-08, Linux 10-18-09 branch builds.  Adding 
vtrunk KW.
Keywords: vtrunk

Comment 24

18 years ago
Verified Fixed on trunk builds
linux 101808 RedHat 6.2
win32 101804 NT 4
mac 101804 Mac OS9
Setting bug to Verified and removing vtrunk keyword
Keywords: vtrunk

Comment 25

16 years ago
Mass removing self from CC list.

Comment 26

16 years ago
Now I feel sumb because I have to add back. Sorry for the spam.


16 years ago
QA Contact: bugzilla → gerardok
You need to log in before you can comment on or make changes to this bug.