Closed Bug 562132 Opened 10 years ago Closed 9 years ago

Closing Fennec twice creates an empty confirmation prompt/dialog

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Maemo
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mbrubeck, Assigned: mfinkle)

References

Details

Attachments

(2 files)

Attached image screenshot
Steps to reproduce:
1. Open at least two tabs.
2. Try to close Fennec (on desktop, use the window close button; on Maemo go to the "switch task" screen and press the X above the Fennec window).
2. While the "Confirm close" prompt is visible, try to close Fennec again.

Results: A second prompt with no text appears above the first (see screenshot).

Expected results: Nothing happens on the second close attempt.
There is a testcase and an other way to repro this behavior in bug 565021
Duplicate of this bug: 568834
tracking-fennec: --- → ?
Attached patch patchSplinter Review
Closing the app using the OS "close X" defeats our fake-modal system. This patch protects the closing code so the close prompt is not shown more than once at a time.
Assignee: mbrubeck → mark.finkle
Attachment #448017 - Flags: review?(mbrubeck)
Attachment #448017 - Flags: review?(mbrubeck) → review+
pushed t m-b:
http://hg.mozilla.org/mobile-browser/rev/18c4932b1725

pushed to m-1.1:
http://hg.mozilla.org/releases/mobile-1.1/rev/d60b726204a1
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Component: Linux/Maemo → General
OS: All → Linux (embedded)
QA Contact: maemo-linux → general
Hardware: All → ARM
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.