Some pages overlaying onto another

VERIFIED DUPLICATE of bug 555904

Status

()

Firefox
Tabbed Browser
VERIFIED DUPLICATE of bug 555904
8 years ago
5 months ago

People

(Reporter: Virtual, Unassigned)

Tracking

({nightly-community})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl-PL; rv:1.9.3a5pre) Gecko/20100427 Minefield/3.7a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100427 Minefield/3.7a5pre

 

Reproducible: Always

Steps to Reproduce:
1. Add to bookmarks this pages
http://www.thespectrum.net/
http://unixmanga.com/
http://www.mangafox.com/
2. Open this 3 bookmarks in one go
3. Close first bookmark (http://www.thespectrum.net/) with keyboard shortcut CTRL+W
Actual Results:  
Third page (http://www.mangafox.com/) shows for brief time in place of second page (http://unixmanga.com/)

Expected Results:  
We shouldn't see this overlaying on pages
Component: General → Layout: View Rendering
QA Contact: general → layout.view-rendering
or simply just open this 3 links with CTRL key and close first and you should see what I;'m taking about :)
Are you using Direct2D?  If so, it might be bug 532106.

That said, I've started seeing this on Linux in the past week or two when opening tabs from Google Reader, but I've only recently started using Google Reader.
I'm on XP like you can see ;p
so I can't use D2D & DW

So anybody can confirm this ?
Cause I can also reproduce it on other PC.

Comment 4

8 years ago
I can confirm what you're seeing.

Comment 5

8 years ago
Regression window for trunk(1.9.2):

Works:
http://hg.mozilla.org/mozilla-central/rev/6cfe70091cfc
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090324 Minefield/3.6a1pre ID:20090324044213

Fails:
http://hg.mozilla.org/mozilla-central/rev/85bd18f6b652
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090326 Minefield/3.6a1pre ID:20090326050203

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6cfe70091cfc&tochange=85bd18f6b652

Regression window for branch(1.9.1):

Works:
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/4552d789ad8f
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090326 Shiretoko/3.5b4pre ID:20090326045125


Fails:
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/cd99dc2701b0
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090327 Shiretoko/3.5b4pre ID:20090327044454

Pushlog:
http://hg.mozilla.org/releases/mozilla-1.9.1/pushloghtml?fromchange=4552d789ad8f&tochange=cd99dc2701b0

Regression: 
When backout https://bugzilla.mozilla.org/attachment.cgi?id=369043 from Minefield/3.6a1pre ID:20090326050203, it was fixed.
So, this is regression of Bug 462673.
Blocks: 462673
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
As in, the UI is actually showing the wrong tab for a bit?
Component: Layout: View Rendering → Tabbed Browser
Product: Core → Firefox
QA Contact: layout.view-rendering → tabbed.browser

Comment 7

8 years ago
In addition comment #0,
Url of  the second and the third tab are not restricted.

(In reply to comment #6)
> As in, the UI is actually showing the wrong tab for a bit?
Label of title bar and tab seems to be no problem.
Only the painting of contents area seems to have a problem.

Comment 8

8 years ago
Created attachment 444960 [details]
testhtml

Here is a similar case.
[STR]
1. Open tabs as follows
  Open testhtml in tab1
  Open http://www.mozilla.org/projects/minefield/ in background tab2
  Open https://bugzilla.mozilla.org/ in background tab3
  Open http://www.mozilla.com/en-US/firefox/firefox.html in background tab4
4.Close tab1
5.then, popup "alert box" and contents of *TAB3* appears.
6.Close "alert box"
7.contents of tab2 appears.

In STEP5, tab2 must appear.
What's the status about fixing this bug ? :)
blocking2.0: --- → ?
OS: Windows XP → All
Hardware: x86 → All

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 555904

Updated

8 years ago
No longer blocks: 462673
Reopening, cause fixing bug #555904, didn't fix this issue.
At least on Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b3pre) Gecko/20100729 Minefield/4.0b3pre
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(In reply to comment #11)
> Reopening, cause fixing bug #555904, didn't fix this issue.
> At least on Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b3pre) Gecko/20100729
> Minefield/4.0b3pre

And you've verified that your build was built with that patch?

Comment 13

8 years ago
I can not reproduce the problem in comment #0 and coment #8 on 
latest hourly.
Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100729 Minefield/4.0b3pre ID:20100730002102
Apparently the build in comment 11 is yesterday's nightly or a non-recent hourly.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 555904
Yep, it's fixed
I simply didn't have the latest build before ;p
blocking2.0: ? → ---
Status: RESOLVED → VERIFIED
Keywords: regression
Keywords: nightly-community
QA Contact: Virtual
You need to log in before you can comment on or make changes to this bug.