location control updated only after page finishes loading

VERIFIED FIXED in M11

Status

SeaMonkey
UI Design
P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: cpratt, Assigned: Radha on family leave (not reading bugmail))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
build number 1999042808
platform tested: windows nt, linux

here's the problem: go to Yahoo!. Look at the location control. It correctly
reads 'http://www.yahoo.com/'. now, click on a link (say, shopping). the
location control does not update until the shopping page has finished loading.

expected result: when you click on a link, at the point the linked page starts
loading, the location control should update to reflect the location of the page
you're in the process of loading. (for example, if you follow a link to another
server somewhere, the location control should show you the current page URL as
long as the 'host contacted, waiting for reply' shows, and change to the linked
page's URL when the host starts sending data down to the client.)

Updated

19 years ago
Assignee: trudelle → don

Comment 1

19 years ago
not my widget, reassigning to don

Comment 2

19 years ago
Assigned to radha.
Assignee: don → radha
Component: XP Toolkit/Widgets → XPApps
Target Milestone: M8
*** Bug 5982 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
Target Milestone: M8 → M14

Comment 4

19 years ago
Another example of this problem is if you type something like "news" in the location bar and hit enter.  It will resolve this to www.news.com (as it should), but the location bar just sits there and says "news" until the page is finished.  As soon as it resolves "news" to "http://www.news.com", it should change the location bar immediately. (Otherwise how do you know where you are going, unless you watch the status messages on the bottom very carefully.)
*** Bug 8919 has been marked as a duplicate of this bug. ***

Comment 6

19 years ago
*** Bug 13109 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Severity: trivial → normal

Comment 7

19 years ago
This bug is a little more than trivial, so upping the severity. It would be nice
to see this fixed for beta. Are there other bugs blocking this?
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Target Milestone: M14 → M11
Fix checked in. Location bar will be updated as soon as a successful conneciton
is made.

Comment 9

19 years ago
apres moi, la deluge. (merci)
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

19 years ago
Looks great! 1999092909 build, NT.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.