Closed Bug 565764 Opened 10 years ago Closed 4 years ago

Scrollbar gets too small to use on long pages

Categories

(Core :: XUL, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: limi, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Advo])

Attachments

(1 file)

(Note: this is filed as part of the “Paper Cut” bugs — we assume that there may be multiple existing bugs on this. Please make them block this bug, and we will de-dupe if they are indeed exactly the same. Thanks!)

I haven't been able to reproduce this myself on OS X, where it seems to work — so if someone knows that it isn't a problem on Windows/Linux either, feel free to close this:

When you load a really long page, I got a report that the scroll bar becomes so small as to be unusuable, ie. just a couple of pixels. There should be a threshold value here so it never becomes smaller than a reasonable size to manipulate.
Depends on: 502292
I loaded this page and the scroll bar thumb stayed large enough.  
http://dev.w3.org/html5/spec/Overview.html

The scroll bar thumb is larger than what you get in IE7 on that page.

This is using this build:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100514 Minefield/3.7a5pre ID:20100514040039
Using the Zune theme.

The thumb in 3.6 is smaller.  I wouldn't call it unusable.  But something must have changed on the trunk which looks like bug 502292 as mardeg pointed out.
On Linux, I have seen the thumb getting "too small". Not as in "unuable", but "visually unpleasing". IIRC this was more of a problem in lists like the one in the Page Info (media) window
On Linux/windows, I have been going crazy with the thumb getting "too small" as in "unusable"
Whiteboard: [Advo]
Duplicate of this bug: 904669
FWIW, I see this bug every day in Thunderbird where some of my folders have many
thousands of mails.
Attached image Thunderbird folder view
So here's what the problem looks like in Thunderbird when you have a folder
with thousands of emails (the www-style mailing list).

It appears as if only the top part of the thumb is taken into account
for its height, i.e. that part where the rounded corner starts.
I suspect it might be a nscoord overflow error in Layout (nsSliderFrame.cpp?)
Component: General → XUL
Product: Firefox → Core
Bug 502292 is already fix this issue.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.