Closed Bug 566483 Opened 12 years ago Closed 8 months ago

Give option to ignore a plugin

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: jhill, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Advo])

(Note: this is filed as part of the “Paper Cut” bugs — we assume that there may be multiple existing bugs on this. Please make them block this bug, and we will de-dupe if they are indeed exactly the same. Thanks!)


Recommendation:
If a user does not want to install a plugin, give them the option to ignore that plugin for good instead of asking each and every time.
In this case we should add a dummy entry into the installed plugins list which basicly says something like "Flash plugin: you did not want to install this", with the option to "remove" it and get the plugin installation bars back
Duplicate of this bug: 771672
Whiteboard: [Advo]
Is this bug about the Plugin Finder Service?  PFS will be removed or redone in bug 836420.
In bug 839206 and bug 836420, I've been working on improving the experience of encountering unknown plugins. There are basically a few objectives we want to achieve:

1) make not having a plugin much less annoying for people who don't want them
2) don't try to install plugins we don't know how to install
3) try not to encourage people to install plugins if we can help it

In my local version of a patch for the former of the bugs, if the plugin is flash we show a door hanger (and anchor icon), if it's java then only the icon, and if it's anything else we don't show anything. In the case where we show a door hanger, there is an option to never show that door hanger again - so people who don't want flash don't have to be pestered.

At least until bug 836428 is resolved, exactly which plugins we will try to handle and what we will do for them is TBD.
I think your proposals do solve this bug.  I would add that almost all sites that use Flash/Java/Silverlight provide a fallback to say "Hey you need to download Flash plugin".   I think pushing the burden to site authors is fine (especially because the super-majority already does it).  

Any examples of sites that just break with no warning with Flash not installed (and no big section that could be empty in the site saying plugin missing, etc)?

I get Access Denied on bug 836428..
(In reply to Bryan Quigley from comment #5)
> I think your proposals do solve this bug.  I would add that almost all sites
> that use Flash/Java/Silverlight provide a fallback to say "Hey you need to
> download Flash plugin".   I think pushing the burden to site authors is fine
> (especially because the super-majority already does it).
> 
> Any examples of sites that just break with no warning with Flash not
> installed (and no big section that could be empty in the site saying plugin
> missing, etc)?

Not that I know of for flash - there is for java though, but I'm looking into that too

> 
> I get Access Denied on bug 836428..

It's a confidential metrics bug, about data on how many people click the "install plugin" button in the current implementation

We're in the process of removing support for plugins (bug 1677160), so I think this bug is irrelevant now.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.