Closed Bug 566484 Opened 12 years ago Closed 12 years ago
Replace "Download retention" with "Download history" in Browser preferences
This is a follow-up to bug 487675 which I had on my list for a while. The label introduced there for the browser.download.manager.retention pref reads "Download retention", thus is accurate with regard to the preference, but somewhat inconsistent with "Download history" defined in sanitize.dtd for the Privacy & Security preferences. The latter follows less the name for the pref but appears to be more intuitive, thus avoiding ambiguities, therefore the proposal to change it in the Browser preferences as well.
This changes the label to "Download history" as proposed, and also changes "Remove downloads" to "Remove list entries" to be more specific what is does (the term "download" is used just above, thus no need to repeat it here). It also matches the identifier with the modified entity names.
BTW, I still wonder if the pref UI implemented in bug 487675 is actually mirrored by real download manager UI behavior, as I don't remember implementing functionality for that pref in our UI.
Good point, but it seems to work. I've just changed the setting from "Never" to "When quitting SeaMonkey", then quit and restarted, and the list was gone.
(In reply to comment #2) > BTW, I still wonder if the pref UI implemented in bug 487675 is actually > mirrored by real download manager UI behavior, as I don't remember implementing > functionality for that pref in our UI. It's handled in nsDownloadManager.cpp [GetRetentionBehavior()].
Right, I just verified that it doesn't need implementation elsewhere. Clearly my bug 487675 comment #0 was somewhat misguided and I did let myself misguide me once again when I re-read it.
> This changes the label to "Download history" as proposed, and also changes > "Remove downloads" to "Remove list entries" to be more specific what is does > (the term "download" is used just above, thus no need to repeat it here). Well, I don't like "Remove list entries:"... if you don't like "Remove download entries:" I could go with "Remove entries:". Either way the entities could be named removeEntries.label/accesskey.
Label and entity titles changed per Neil's comment #6, it's a bit longer but still fits well into the dialog window (at least on WinXP). > (comment #4) It's handled in nsDownloadManager.cpp [GetRetentionBehavior()]. I figured that toolkit is taking care of it somewhere. Carrying forward r=IanN from previous patch.
Comment on attachment 445943 [details] [diff] [review] Proposed patch (v2) >-<!ENTITY removeDownloads.label "Remove downloads"> [Odd; I was expecting this to end in a :]
Attachment #445943 - Flags: superreview?(neil) → superreview+
Me too, but neither does any of the other labels followed by some box end in a colon, thus I kept it this way. Making label styles consistent across preference dialogs may be a bug on its own... Thanks for the reviews, push on trunk please.
Whiteboard: [c-n: comm-central]
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Whiteboard: [c-n: comm-central]
You need to log in before you can comment on or make changes to this bug.