Closed Bug 567125 Opened 9 years ago Closed 3 years ago

ALT+O access key for compose window's Format menu conflicts with contacts sidebar: Change "Search f_o_r:" label to "Search Co_n_tacts"

Categories

(Thunderbird :: Message Compose Window, defect, minor)

x86
All
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 52.0

People

(Reporter: gerrit, Assigned: bugzilla2007)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9 GTB7.0 (.NET CLR 3.5.30729)
Build Identifier: (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100317 Thunderbird/3.0.4

I used to be able to highlight text and press Alt-O, C, L, Enter, to change the text to the last color used.  The Alt-O no longer works -- it now selects the Search For box.

Reproducible: Always

Steps to Reproduce:
1. Mark some text in a message
2. Press Alt-O.  
3. This should activate the Format menu but it activates Search For instead.
Actual Results:  
Search For activated

Expected Results:  
Format menu item should be activated
When was it working in 2.x ? 

Are your extensions all working on your 3.0 copy ?
Yes, 2.x worked fine.  I'm not sure what you mean by 'extensions'.
Extensions are things you install on top of Thunderbird (see https://addons.mozilla.org/en-US/thunderbird/). Can you try safe mode? (see https://support.mozillamessaging.com/en-US/kb/Safe+Mode for more information)
This is a very simple repeatable bug here, but you're asking about extensions and safe mode.  Are you not able to reproduce it?  All you have to do is hit Alt-O while editing an email, and the Search For box is activated instead of the Format menu item.  They both show Alt-O as their hot key, which seems like an error to me.
Confirmed here on 

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4) Gecko/20100614 Lightning/1.0b2pre Lanikai/3.1.1pre ID:20100614034943

ALT+O is default short-key to open menu-->Format on compose window, but when menu-->views-->contactssidebar (F9) is flagged, ALT+O move focus on "search for" text box on contacts sidebar.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Can't use hot keys for text color change any more → ALT+O short-key in compose window conflict with contacts sidebar
UI and accessibility guru can we have some thoughts ?
The Contacts sidebar should get a different shortcut. Alt+O should open that format menu no matter what, IMO.
With the contacts sidebar open I can reproduce this on Linux too.
Having things steal the shortcut from each other sounds a bit unpredictable to me, so the question is, do we want to bind the "Search For" focus shortcut to something else?
Disabling it could be a bad idea, because once you've tabbed into the compose text area, it's stuck there and will just give you tabs in your letter apparently.
OS: Windows XP → All
Thomas, can you suggest a way, and a person, to fix/move this forward?
Flags: needinfo?(bugzilla2007)
I don't have a good idea how to fix this. All access keys of current labels are taken (also considering attachment pane, attachment reminder notification bar, inline find bar). Even reshuffling them I don't see any way.(Note that Add-To... access keys on contacts side bar require focus on contacts side bar which makes them exclusive to the bar, so they don't all intersect with the rest of the screen).

I note that in case of double access keys, normally there should be focus alternation.
Try alt+l with find bar + attachment reminder bar open to see focus alternation.
But I'm not sure if the same would work well for alt+o.

So we could only add another random character to the label:
"Search for (_y_):" (where the y is reminiscent of a filter...)
Which is odd.

Or, we could remove the access key altogether (probably violating ux rules), and perhaps have only Ctrl+Shift+K as a filter shortcut to access that field. Also odd, especially the removal of the access key. (Perhaps if we remove the label, and have just "Search..." as emptytext, with search details in tooltip).

So really, there's no good solution.

Wayne, comments/ideas?
Flags: needinfo?(bugzilla2007)
I suggest change "Search For" to "Search Contacts" (which is what it probably should be in the first place) and have alt+N be it's shortcut.  

(The initial mistake of course is having allowed somone to adding anything, in this case the sidebar, that could overried something in the main pane, i.e. compose.)
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #11)
Brilliant!
Summary: ALT+O short-key in compose window conflict with contacts sidebar → ALT+O access key for compose window's Format menu conflicts with contacts sidebar: Change "Search f_o_r:" label to "Search Co_n_tacts"
Whiteboard: [good first bug]
Paenglab, are you ok ui-wise with the change proposed by Wayne and myself?

To resolve the access key conflict, change "Search f_o_r:" label to "Search Co_n_tacts" (which is clearer anyway...)
Flags: needinfo?(richard.marti)
Yes, this is a change that makes sense.
Flags: needinfo?(richard.marti)
Severity: normal → minor
Richard, as approved by you in comment 14. Thanks.
Assignee: nobody → bugzilla2007
Status: NEW → ASSIGNED
Attachment #8801528 - Flags: ui-review?(richard.marti)
Attachment #8801528 - Flags: review?(richard.marti)
Comment on attachment 8801528 [details] [diff] [review]
Bug567125-SearchContactsLabel.patch

r=me with changing searchContactsBox to searchContacts. There is no box and no need to name it box and searchContacts isn't used in the tree.
Attachment #8801528 - Flags: ui-review?(richard.marti)
Attachment #8801528 - Flags: review?(richard.marti)
Attachment #8801528 - Flags: review+
Nitfix made. Forwarding r=paenglab from comment 16.

Fwiw, it was searchInput.label before, Input short for InputBox, so there was a reference to the element controlled by the label in the label name. In the previous patch, I tried doing the same by using "SearchContactsBox.label", indicating that this label controls the SearchContacts InputBox.
But it's fine to me either way.
Attachment #8801528 - Attachment is obsolete: true
Attachment #8801984 - Flags: review+
Keywords: checkin-needed
Whiteboard: [good first bug]
https://hg.mozilla.org/comm-central/rev/abe8046587710e2e1a2ae1a3424ccc33fa3af272
Bug 567125 - Change "Search for:" label to "Search Contacts:" to resolve access key conflict. r=paenglab
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 52.0
You need to log in before you can comment on or make changes to this bug.