Header should be as heigh as the blue "selected" background of a panelitem

RESOLVED WORKSFORME

Status

()

--
trivial
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: mkohler, Unassigned)

Tracking

({uiwanted})

Trunk
uiwanted
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [AddonsRewrite])

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
Created attachment 447031 [details]
Screenshot

When you click on "Get Add-ons", the blue border around that item is bigger than the header. It should be as high as the header. See the screenshot for more information.
(Reporter)

Comment 1

9 years ago
Created attachment 447032 [details] [diff] [review]
Patch
Assignee: nobody → michaelkohler
Status: NEW → ASSIGNED
Attachment #447032 - Flags: review?(dtownsend)
bug 562949 could be marked as a dupe since you have patch here.
(Reporter)

Updated

9 years ago
Duplicate of this bug: 562949
Created attachment 447033 [details]
latest trunk height diff

Micheal this is what I see as a height with latest trunk, I see it doesn't match your screenshot, mine show the opposite scenario.

Comment 5

9 years ago
This bug should examine after fixing of Bug 557916
(Reporter)

Comment 6

9 years ago
Oh, right.
Whiteboard: [AddonsRewrite]
Comment on attachment 447032 [details] [diff] [review]
Patch

You need to make sure the header and the category boxes are sized in the same way I think. Currently one is sized by px and the other by em. The latter is probably the correct choice but you may run into problems with the different font sizes.
Attachment #447032 - Flags: review?(dtownsend) → review-
Isn't it a coincidence that the tabs of the addon-manager sidebar and the title of its main pane are approximately the same height? I could imagine one theme using small tabs (just high enough for the text using a font similar to that for the menus, more or less as in the browser sidebar) and another one expanding them vertically until those tabs taken together occupy the whole height available, while the main pane title would be "just a few percent higher" than a default <h1> in both cases.
It is a coincidence yes, however I tend to agree that it is fairly ugly looking to have them so close to being the same yet still different. So I think either we should make them the same or more obviously different. It isn't a terribly high priority to fix this though.
Keywords: uiwanted
(Reporter)

Comment 10

9 years ago
(In reply to comment #9)
> It is a coincidence yes, however I tend to agree that it is fairly ugly looking
> to have them so close to being the same yet still different. So I think either
> we should make them the same or more obviously different. It isn't a terribly
> high priority to fix this though.

I will a take a look at this bug again once bug 557916 is fixed..
Depends on: 557916
(Reporter)

Comment 11

8 years ago
Since there will be another css-redesign after the Summit, this bug will likely fix then, or will not even exist anymore.

https://wiki.mozilla.org/Firefox/Projects/Extension_Manager_Redesign/design#New_Theme_Wireframes
(Reporter)

Comment 12

8 years ago
This is not a problem anymore since the AddonsManager has been redesigned.
Assignee: michaelkohler → nobody
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.