Closed Bug 56923 Opened 20 years ago Closed 9 years ago

Importing Bookmarks from Network doesn't work

Categories

(SeaMonkey :: Bookmarks & History, defect, P3)

x86
Windows 2000
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME
Future

People

(Reporter: Matti, Unassigned)

References

Details

Open "Manage Bookmarks, Import Bookmarks"
Select a .html file from a network drive, select file and press OK.
Nothing happends.
It works with a local file.

It seems to be a problem with the UIN name : //laptop/c/test.html
Will try and look at this in the morning (when I get to work) and see if I can
reproduce it.
I can confirm this... I used the same file for both Local and Remote... the one
with the UNC didn't work (no error, no crash, no import, nothing)... I might as
well have just hit Cancel.
2000110604 on Win2k
Status: UNCONFIRMED → NEW
Ever confirmed: true
Netscape Nav triage team: this is not a Netscape beta stopper.  Reassigning to 
vishy
Assignee: ben → vishy
Keywords: nsbeta1-
Marking nsbeta1- bugs as future to get off the radar
Target Milestone: --- → Future
This bug probably depends on bug 66194.
Could you try again?  At least some problems with UNC paths have been resolved
in 0.9.3.  You might now be able to access the bookmarks using a file requester
or the "file://///" syntax described in bug 66194.
Depends on: 66194
This doesn't work with an 1h old CVS build.

JS Output:
Error: [Exception... "Component returned failure code: 0x8000ffff
(NS_ERROR_UNEXPECTED) [nsIRDFDataSource.DoCommand]"  nsresult: "0x8000ffff
(NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://communicator/content/bookmarks/bookmarksOverlay.js :: anonymous :: line
767"  data: no]
Source File: chrome://communicator/content/bookmarks/bookmarksOverlay.js
Line: 767
Depends on: 101953
Can someone confirm this is a problem, esp Mozilla 0.9.5 or later?
Yes, I can confirm that this is still broken with mozilla 20011023.. (1h old CVS)
I get the same error in the JS console that I have already posted (2001-08-28 14:00)
it is still broken
No longer depends on: 66194
*** Bug 101523 has been marked as a duplicate of this bug. ***
*** Bug 130269 has been marked as a duplicate of this bug. ***
*** Bug 137607 has been marked as a duplicate of this bug. ***
Summary: Import Bookmarks from Network -=> no function → Importing Bookmarks from Network doesn't work
*** Bug 157660 has been marked as a duplicate of this bug. ***
Reassigning to a real person.
Assignee: vishy → ben
Original bug poster here.   I copied the Bookmark file to my local hard drive, 
and it still didn't import, so it's not only a network issue.   If it helps you 
in debugging, I am using Windows 2000 professional service pack 2, with Mozilla 
1.1a
Original poster with a correction to my last post, and recommendation that this 
bug be closed as a duplicate of bug 66194.


When trying to see if this would import from my local drive, I tried to import 
into a profile that already had all of these bookmarks - and it seems that 
Mozilla 1.1a is smart enough to resolve the duplicates and ignore my attempts.

When I did it a different way, and imported bookmarks from the local drive into 
a profile that had no special bookmarks at all, it worked perfectly and 
imported using the "manange bookmarks" tools, import.

So from my symptoms, I agree that this is a problem with importing a network 
file, not with importing bookmarks all together.
*** Bug 157660 has been marked as a duplicate of this bug. ***
This is no dupe of bug 66194
This happen here with Mozilla 1.1 unter Windows XP. Import and export simply do
nothing when the selected filename is on a network drive. Very annoying.
I get this in JS Console in 1.2b build 2002101612, W2k SP2, j2sdk 1.4.1

Error: [Exception... "Component returned failure code: 0x8000ffff
(NS_ERROR_UNEXPECTED) [nsIRDFCompositeDataSource.DoCommand]"  nsresult:
"0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://communicator/content/bookmarks/bookmarks.xml#bookmarks-tree.doBookmarksCommand()
:: doBookmarksCommand :: line 25"  data: no]
Source File:
chrome://communicator/content/bookmarks/bookmarks.xml#bookmarks-tree.doBookmarksCommand()
Line: 25
*** Bug 185404 has been marked as a duplicate of this bug. ***
This still appears to be the case with 1.3a on both Win2K and XP Home.
Error messages in javascript console the same as reported below.
Blocks: 101953
No longer depends on: 101953
I can still confirm this bug with 1.3 final.
Using a UNC like

\\pantertje\apps\mozilla\Maarten Afman moz13\7pj69csf.slt\bookmarks.html

OR

file://///pantertje/apps/mozilla/Maarten%20Afman%20moz13/7pj69csf.slt/bookmarks.html


doesn't do anything at all but gives the following error in the JS console :

   Error: [Exception... "Component returned failure code: 0x8000ffff
(NS_ERROR_UNEXPECTED) [nsIRDFCompositeDataSource.DoCommand]"  nsresult:
"0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://communicator/content/bookmarks/bookmarks.xml#bookmarks-tree.doBookmarksCommand()
:: doBookmarksCommand :: line 25"  data: no]
   Source File:
chrome://communicator/content/bookmarks/bookmarks.xml#bookmarks-tree.doBookmarksCommand()
Line: 25

Evidently the following is the case
- the bug as originally reported is still present
- file:///path and \\UNC\PATH\s DO NOT work, and..
- mapped network drives DO work!
- So it has to do with file name resolving 

What should be checked? 
- I think the code sequence that interprets the filenames at the opening of the
bookmarks .HTML file for import. :-)

Here is the source of the method from bookmarks.xml

      <method name="importBookmarks">
        <body><![CDATA[
          try {
            const kFilePickerContractID = "@mozilla.org/filepicker;1";
            const kFilePickerIID = Components.interfaces.nsIFilePicker;
            const kFilePicker =
Components.classes[kFilePickerContractID].createInstance(kFilePickerIID);
         
            const kTitle = this._bundle.GetStringFromName("SelectImport");
            kFilePicker.init(window, kTitle, kFilePickerIID["modeOpen"]);
            kFilePicker.appendFilters(kFilePickerIID.filterHTML |
kFilePickerIID.filterAll);
            var fileName;
            if (kFilePicker.show() != kFilePickerIID.returnCancel) {
              fileName = kFilePicker.fileURL.spec;
              if (!fileName) return;
            }
            else return;
          }
          catch (e) {
            return;
          }
          var seln = null;
          try {
            seln =
this.treeBuilder.getResourceAtIndex(this.treeBoxObject.selection.currentIndex).Value;
          }
          catch(ex) {
            seln = this.rdf.GetResource("NC:BookmarksRoot").Value;
          }
          var args = [{ property: this.NC_NS + "URL", literal: fileName}];
          this.doBookmarksCommand(seln, this.NC_NS_CMD + "import", args);
        ]]></body>
      </method>

Succes with this one 
Confirmed on 1.3 on Win XP
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
"Import bookmarks" does nothing if the file is on a network drive, either
mounted as a drive letter or not.
Product: Browser → Seamonkey
WFM.

Windows XP SP1
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051127
SeaMonkey/1.5a
Assignee: bugs → nobody
QA Contact: claudius → bookmarks
This seems to work
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.