Use last part of URL for window title if document has no TITLE

NEW
Unassigned

Status

SeaMonkey
UI Design
--
enhancement
18 years ago
5 years ago

People

(Reporter: Matthew Paul Thomas, Unassigned)

Tracking

({helpwanted})

Trunk
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
To reproduce:
* Open a document which which has no TITLE, such as
  <http://bugzilla.mozilla.org/showattachment.cgi?attach_id=13590>.
* Look at the title bar.

What you should see (besides the browser name and build id):
* The text after the last `/' in the URL, e.g.
  `showattachment.cgi?attach_id=13590'.
* If there is no text after the last `/' in the URL, then the string between the
  last `/' (including the `/') and the one before it (excluding the `/'), e.g.
  `bugzilla.mozilla.org/'.

What you actually see (besides the browser name and build id):
* Nothing.

Occurs with:
* Build 2000101620, Mac OS 9.0

Does not occur with:
* Internet Explorer 5.0, Windows 98
(Reporter)

Updated

18 years ago
Blocks: 56995
this is also the behavior i see on 4.x (mac, winnt and linux). it'd be a rather
useful enhancement (and improvement) to add this.
Severity: minor → enhancement
Keywords: helpwanted

Comment 2

17 years ago
This should also happen for text/css and application/x-javascript files:

http://hixie.ch/resources/style/spaced.css
http://www.cs.hmc.edu/~jruderma/mozilla/proptree/proptree.js
Is this in the right component?

Blake, Ben: any chance of pointing me at the right files to fix this?

Gerv
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Reporter)

Comment 4

17 years ago
*** Bug 113134 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
This doesn't really block 56995, as is indicated.

Comment 6

17 years ago
My title suggestion, from the dupe:

foo.png - 102x309 pixels
alacazam.txt

When no filename is available:
www.foo.com could use 'www.foo.com' as the title.
www.foo.com/bar/ could use '/bar/' as the title.

The cases where the above return image/* or text/plain are rare, but should
be covered.
*** Bug 118856 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
Well, this appears to have been addressed in 0.9.8, at least for images.

Recommend closing resolved fixed.

Comment 9

16 years ago
Although images do seem to behave correctly, this is not fixed (in 2002030508)
for the original example URL given. (Or for other useful files, such as plain
text files viewed from hard disk.) 

These cases still end up with blank titles.

Comment 10

16 years ago
*** Bug 148727 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
image title was fixed in bug 118915

Comment 12

16 years ago
*** Bug 156421 has been marked as a duplicate of this bug. ***

Comment 13

15 years ago
*** Bug 198897 has been marked as a duplicate of this bug. ***

Comment 14

15 years ago
removing dependency per comment 5.
No longer blocks: 56995

Comment 15

14 years ago
*** Bug 259635 has been marked as a duplicate of this bug. ***
Product: Core → Mozilla Application Suite
Assignee: bugs → nobody
Status: ASSIGNED → NEW
Priority: P3 → --
QA Contact: bugzilla → guifeatures
Target Milestone: Future → ---

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design

Comment 16

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 17

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 18

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 19

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 20

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 21

8 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
You need to log in before you can comment on or make changes to this bug.