Bugzilla quicksearch should return partial matches for Alias field

RESOLVED DUPLICATE of bug 527641

Status

()

Bugzilla
Bugzilla-General
--
enhancement
RESOLVED DUPLICATE of bug 527641
8 years ago
8 years ago

People

(Reporter: Thomas D. (currently busy elsewhere), Unassigned)

Tracking

Details

Bugzilla quicksearch currently searches Alias field (without letting the user know in the summary on top of result list), but we only search for full matches in that field. Partial matches would be helpful, too, and they won't hurt those who know the exact alias which will still take them straight to the bug.

STR

0 Bug 544553 currently has the alias "BugzillaForHumans"

1 You are looking for existing bugs relating to your problem
1a) with no knowledge about the alias (just searching for relevant bugs)
1b) with partial knowledge about the alias ("was it BugzillaForPeople, or BugzillaForStarters?")
1c) with full knowledge about the alias
 
2 You are doing bugzilla quicksearches
2a) https://bugzilla.mozilla.org/buglist.cgi?quicksearch=bmo for humans
2b) https://bugzilla.mozilla.org/buglist.cgi?quicksearch=bugzillafor
2c) https://bugzilla.mozilla.org/buglist.cgi?quicksearch=bugzillaforhumans

Actual result

2a) quicksearch=bmo for humans
-> this will actually find the bug, but only because of the bug's title. If "humans" was a relevant word that happens to be NOT in the title, but ONLY in the alias, we wouldn't find anything (this bug).

2b) quicksearch=bugzillafor
-> this will not find the bug, as the last part of the alias is missing and we are only finding exact matches for the alias (this bug)

2c) quicksearch=bugzillaforhumans
-> only searching for the exact alias will return the bug (and take you right there, as it should)

Expected result

2a), 2b) quicksearch=bmo for humans / quicksearch=bugzillafor
-> this should find the bug (and display a result list), based on partial match of "humans" or "bugzillafor" compared against the value of the alias field: "BugzillaForHumans"
-> if it's only one match, take me straight to the bug

2c) quicksearch=bugzillaforhumans
-> searching for the exact alias will return the bug, and take me right there (as it does now)

Rationale: We often give alias names to important meta bugs.
- We should make it easier for average users to discover these (and work their way forward from there, avoid duplicates etc.)
- and we should make it easier for advanced users to find aliases they know of but don't remember the exact wording or spelling
(Reporter)

Updated

8 years ago
Severity: normal → enhancement

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 527641
You need to log in before you can comment on or make changes to this bug.