If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Growl notifications do not use the Thunderbird icon

RESOLVED WONTFIX

Status

Thunderbird
OS Integration
--
minor
RESOLVED WONTFIX
7 years ago
5 years ago

People

(Reporter: Pratul Kalia, Assigned: andreasn)

Tracking

({ux-consistency})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.4) Gecko/20100526 Thunderbird/3.1

All Growl notifications that Thunderbird generates, use some "message" icon and not the application icon itself, as it should be.

Reproducible: Always
(Reporter)

Comment 1

7 years ago
Created attachment 449518 [details]
Incorrect icon

Comment 2

7 years ago
Isn't that just the kNewMailAlertIcon icon (chrome://messenger/skin/icons/new-mail-alert.png) ?
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US;

> not the application icon itself, as it should be.

Why should it be the application icon ? (when I get growl notifications from IM it pushes the icons from the faces of my friend not from the application, so can you point out a document which backs up your saying ?
Keywords: ux-consistency
(Reporter)

Comment 4

7 years ago
IMHO, Adium using the user's photo instead of the application icon is still valid. An IM is meant to be instant, it would be quicker to see the user's photo instead of just reading the user's name on the growl. Also, all Adium notifications like app updates use the Adium icon. Other OS X applications still use the application icon (Firefox, Transmission use their respective icons, shell scripts use the Terminal.app icon)

Since there are no written guidelines for Growl, I support this in favor of consistency. It still makes no sense to me to use a GNOME/Tango like icon on OS X. The Thunderbird icon looks like the best choice.
Severity: normal → minor
(In reply to comment #2)
> Isn't that just the kNewMailAlertIcon icon
> (chrome://messenger/skin/icons/new-mail-alert.png) ?

Yep so replacing this icon on the proper theme with a thunderbird icon would fix this. Andreas, would you be willing to do this ?
(Assignee)

Updated

7 years ago
Assignee: nobody → nisses.mail
(Assignee)

Comment 6

7 years ago
Created attachment 474712 [details] [diff] [review]
possible fix

This uses the official or unofficial icon from branding. Only tried with unoffial branding so far, and it seems it might be some scaling issues happening. Will rebuild with official branding and see if it still happens. If so, I'll do another patch.
(Assignee)

Comment 7

7 years ago
Created attachment 474763 [details] [diff] [review]
second patch

This might work too. It uses the sharp mailicon32.png graphics. Just need to test it some more, since I'm uncertain if it picks up the unofficial branding properly or not (it might just be a cache issue).

Comment 8

6 years ago
Confirming per the comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

6 years ago
Comment on attachment 474763 [details] [diff] [review]
second patch

Requesting review.
Or is this patch already merged?
Attachment #474763 - Flags: review?(bwinton)
Comment on attachment 474763 [details] [diff] [review]
second patch

Andreas: did you get chance to test this yet?
Attachment #474763 - Flags: review?(bwinton)

Comment 11

6 years ago
I can confirm, that it looks better with the nativ Thunderbird icon instead of the current mail icon. For my build I've used:

#define kNewMailAlertIcon "chrome://branding/content/icon64.png"

Comment 12

5 years ago
Growl support has been removed from the current versions.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX

Comment 13

5 years ago
Hm, who is using this kNewMailAlertIcon now? Growl can't because its removed and the Notification Center uses the application icon per default. Does any other service use this?

Comment 14

5 years ago
Sorry, here is the proof (bug 792793).

Nomis101, it seems to be used here:
http://mxr.mozilla.org/comm-central/source/mailnews/base/src/nsMessengerOSXIntegration.mm#389
Depends on: 792793

Comment 15

5 years ago
(In reply to :aceman from comment #14)
> Sorry, here is the proof (bug 792793).
> 
> Nomis101, it seems to be used here:
> http://mxr.mozilla.org/comm-central/source/mailnews/base/src/
> nsMessengerOSXIntegration.mm#389
Yes, but thats the part for the AlertsService, which means for the Notification Center on Mac, which is not using this. So I wondered if kNewMailAlertIcon is obsolete now.

Comment 16

5 years ago
It is using the kNewMailAlertIcon constant. Or do I miss something?

Comment 17

5 years ago
(In reply to :aceman from comment #16)
> It is using the kNewMailAlertIcon constant. Or do I miss something?
What I want to say is. Notification Center on Mac doesn't support images. It is using the apps icon per default and you can't change this. But NC is the only AlertService for Mac in Gecko now. kNewMailAlertIcon is currently defined as new-mail-alert.png, which is this envelope. But NC is using the Thunderbird application icon. So, if only NC is using kNewMailAlertIcon, and nothing else, than its obsolete (because it can't be used from NC). Or are there any plans for an additional AlertService for Mac?
You need to log in before you can comment on or make changes to this bug.