[Direct2D] D2D leaves text cursor artifacts when using enter or backspace in a <textarea>

RESOLVED DUPLICATE of bug 571046

Status

()

defect
RESOLVED DUPLICATE of bug 571046
9 years ago
9 years ago

People

(Reporter: mozilla.bugs, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100610 Minefield/3.7a5pre (.NET CLR 3.5.30729) ID:20100610035756

When filling in a textarea and a carriage return is pressed, D2D adds gray artifacts where the cursor has been.  This can also occur when using the backspace key, but it only appears to do that after the carriage return has been used.

Also, these artifacts are rarely the same brightness, and they can move with the text leaving imprints behind.  To remove them, you can type over them or move the text cursor somewhere else in the textarea and it resets the view.

STR
1. Enable D2D
2. Open a page with a textarea
3. Type in it and press enter several times
4. Keep typing and use the backspace key

If needed, I can provide information on my graphics drivers, but it's late and I'm lazy.
Could you confirm this is not just bug 571046?
Reporter

Comment 2

9 years ago
It sounds like a duplicate, but when the fix for that bug is landed, I will verify that this got fixed by that patch.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 571046
You need to log in before you can comment on or make changes to this bug.