[D2D] Random vertical lines appearing.

RESOLVED FIXED

Status

()

defect
P1
major
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: streetwolf, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100608 Minefield/3.7a5pre firefox/3.6
Build Identifier: 20100609102629

Vertical lines are appearing randomly.  Moving a window off screen and back will produce them.  Typing in a test area and then hitting Backspace will also produce them.

Reproducible: Always




Probably came in with either of these:

Bug 568495
Bug 555353
(Reporter)

Updated

9 years ago
Blocks: d2d
Version: unspecified → Trunk
(Reporter)

Updated

9 years ago
Priority: -- → P1
Confirming this behavior.
Scrolling will fix it.
Setting to new, I see the same when editing text in a text box and using the backspace key to erase, light gray vertical lines apppear.  

In fact, you don't even have to type any letters, space off the cursor several spaces from the left edge and use the backspace key - lines will appear.

Tested using latest hourly build, Win7 X64
Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100608 Minefield/3.7a5pre ID:20100609103918
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Random vertical lines appearing. → [D2D] Random vertical lines appearing.
I suspect this is somehow related to 555353. More specifically this is most likely the CombineWithGeometry bug that is also responsible for a number of other problems. This particular case can probably be fixed relatively easily. Investigating.

Comment 5

9 years ago
I get this issue a lot when scrolling on googlecode pages.
Example: http://code.google.com/p/pcsx2/source/detail?r=3187
(scroll down until the bar on the left starts to move along with the visible area)

Comment 6

9 years ago
Confirmed :)
We know the cause of this, we're working on a 'proper' fix in conjunction with the fixes for anti-aliased clipping.
Duplicate of this bug: 571455
Duplicate of this bug: 573276
(Reporter)

Comment 10

9 years ago
It appears https://bugzilla.mozilla.org/show_bug.cgi?id=567295 has fixed this problem, at least om my end.
I no longer can see the vertical lines either using the latest hourly build.

Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:2.0b2pre) Gecko/20100630 Minefield/4.0b2pre ID:20100630152851
Same here.  No vertical lines when using the backspace while editing textboxes.
This is indeed fixed by bug 567295.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.