Closed Bug 571783 Opened 10 years ago Closed 9 years ago

Split-menu buttons are misaligned in the Firefox button menu

Categories

(Firefox :: Theme, defect)

All
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 4.0b7
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: u88484, Assigned: dao)

References

Details

Attachments

(5 files)

The print menu entry in the Firefox menu button has some alignment issues due to the split-menu button.  The split-menu button has padding around it that pushes the arrow away from the right side of the menu and this in turn also misaligns the shortcut key in relation to the other ones in the menu.

Can't really remove the padding because the click area would be very small so I think the fix is to actually fix how split-menu buttons are "selected".  When the mouse hovers over the arrow, the entire entry should be selected, not just the arrow.
Attached image Screenshot
Print is wonky for some reason -- here, I don't see the shortcuts at all, but "Print" and the ">" highlight like separate buttons (hovering over Print shows everything other than the > highlighted, and there's no submenu that opens until I hover over the ">").  The other items with submenus (History, Customize) work normally.
blocking2.0: --- → ?
(In reply to comment #3)
> Print is wonky for some reason -- here, I don't see the shortcuts at all,

That's a problem, but one with the entire Firefox menu - there are no keyboard shortcuts. I suspect that's because they're still on the menuBar

> "Print" and the ">" highlight like separate buttons (hovering over Print shows
> everything other than the > highlighted, and there's no submenu that opens
> until I hover over the ">").  The other items with submenus (History,
> Customize) work normally.

I'm pretty sure that's the design. Clicking print will do so; clicking the side arrow gets you more options. Faaborg?
(In reply to comment #4)
> > Print is wonky for some reason -- here, I don't see the shortcuts at all,
> 
> That's a problem, but one with the entire Firefox menu - there are no keyboard
> shortcuts. I suspect that's because they're still on the menuBar

see bug 571750

> > "Print" and the ">" highlight like separate buttons (hovering over Print shows
> > everything other than the > highlighted, and there's no submenu that opens
> > until I hover over the ">").  The other items with submenus (History,
> > Customize) work normally.
> 
> I'm pretty sure that's the design. Clicking print will do so; clicking the side
> arrow gets you more options.

Yep.
Assignee: nobody → dao
Status: NEW → ASSIGNED
Component: Menus → Theme
OS: All → Windows 7
QA Contact: menus → theme
Summary: Print's keyboard shortcut and split-menu button is misaligned in the Firefox menu button → Print's split-menu button is misaligned in the Firefox menu button
>I'm pretty sure that's the design. Clicking print will do so; clicking the side
>arrow gets you more options. Faaborg?

Only tweak we need is that hovering on Print should still expand the submenu after a short delay.

>here, I don't see the shortcuts at all,

The main menu under the Firefox button will be switching over to a custom panel, white background and possibly larger icons.  In this context it won't be as strange that the shortcuts are missing.  Also, we are interested in creating a shortcut to display all shortcuts similar to "?" in gmail.
Can this be marked resolved now since the shortcut keys have been removed?
Looks like it, yeah.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
On Win7 the split-menu button is still misaligned compared to History/Customize.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(In reply to comment #9)
> On Win7 the split-menu button is still misaligned compared to
> History/Customize.

Can you take a screenshot because I'm not seeing it?
Oh, you're talking about the arrow. I see now.
This issue will be addressed when the main Firefox menu changes to a custom panel, instead of a native menu, with custom styling.

I'm duping this change forward to bug 583386 so that we can centralize discussion, work, and blocking status for beta 4.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 583386
Keeping this open for proper tracking.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
blocking2.0: ? → betaN+
I get this weirdness using the Classic theme on Mozilla/5.0 (Windows NT 6.0; rv:2.0b4pre) Gecko/20100817 Minefield/4.0b4pre ID:20100817040615
The same for "New Tab" menu entry.
Is this the same bug or different?
(In reply to comment #15)
> Created attachment 467120 [details]
> Print menu entry appears to be two sections | Print | > |
> 
> I get this weirdness using the Classic theme on Mozilla/5.0 (Windows NT 6.0;
> rv:2.0b4pre) Gecko/20100817 Minefield/4.0b4pre ID:20100817040615
> The same for "New Tab" menu entry.
> Is this the same bug or different?

They are split-menu buttons and meant to be like that.  Clicking new tab or print performs that action while the first entry in the submenu also performs the same action.
Duplicate of this bug: 589151
(In reply to comment #16)
> They are split-menu buttons and meant to be like that.  Clicking new tab or
> print performs that action while the first entry in the submenu also performs
> the same action.
I see. Hope there'd plenty of explanatory material at http://www.mozilla.com/firefox/4.0/firstrun/ of this new UI component.
(In reply to comment #18)
> I see. Hope there'd plenty of explanatory material at
> http://www.mozilla.com/firefox/4.0/firstrun/ of this new UI component.
It's not really new, Microsoft use it a lot in Windows 7 :
http://www.zath.co.uk/wp-content/uploads/2009/10/windows-7-paint-ribbon-menu-desktop-background.jpg
http://www.windowsvienna.com/Pictures/Windows%207/PDC/Windows%207%20Start%20Menu.jpg
About that, I think the style should reflect the native style.
(In reply to comment #19)
Per attached the "split-menu button" doesn't exist on Vista's "Windows Classic" theme.
I'm not UI expert, but I believe for classic theme only the elements on Classic.xaml soul be used (see http://msdn.microsoft.com/en-us/library/aa970773.aspx)
If I remember correctly the Firefox button will be displayed by default only with Aero theme.
Looks like bug 580738 might be the right place for Classic theme.
Apologies on the bug spam =(
The split menus' arrows still are aligned differently from the non-split menu's arrows.
(In reply to comment #23)

The print menu's been fixed so now it only happens on developer.
(In reply to comment #24)
> (In reply to comment #23)
> 
> The print menu's been fixed so now it only happens on developer.

If anything, developer is the only one that is correct.  New Tab and Print are 13 pixels from the edge while Developer is 9.  In the submenus the arrows are 11 pixels from the edge.
Summary: Print's split-menu button is misaligned in the Firefox menu button → Split-menu buttons are misaligned in the Firefox button menu
Attached patch patchSplinter Review
Attachment #472136 - Flags: review?(gavin.sharp)
Attachment #472136 - Flags: review?(gavin.sharp) → review+
http://hg.mozilla.org/mozilla-central/rev/79d0beec27b5
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b6
Verified fixed using hourly build Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100910 Firefox/4.0b6pre from cset cca361001fda
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.