If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Meta] Change graphical appearance of Firefox Menu to match mockups

RESOLVED DUPLICATE of bug 583386

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 583386
7 years ago
7 years ago

People

(Reporter: Terepin, Unassigned)

Tracking

({meta})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a6pre) Gecko/20100613 Minefield/3.7a6pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a6pre) Gecko/20100613 Minefield/3.7a6pre

Current initial implementation of Firefox Menu is using system's default appereance. It should be changed to look more modern and slick.

Marking as Win bug only, as there is no mockup how will look menu in Linux. Probably different.

Reproducible: Always
(Reporter)

Updated

7 years ago
Blocks: 556174

Comment 1

7 years ago
What do you mean by "using system's default appearance" and what exactly are your proposing that should be changed?

Comment 2

7 years ago
(In reply to comment #1)
> What do you mean by "using system's default appearance" and what exactly are
> your proposing that should be changed?

I think he means that it should look exactly as on the mock-ups.

Comment 3

7 years ago
(In reply to comment #2)
> (In reply to comment #1)
> > What do you mean by "using system's default appearance" and what exactly are
> > your proposing that should be changed?
> 
> I think he means that it should look exactly as on the mock-ups.

Ok, I'll dig around and try to figure out exactly which mockups since it wasn't linked to here.  I was curious as to exactly what he was looking for since he said "modern and slick".
(Reporter)

Comment 4

7 years ago
Upps, I forgot the mockup.
https://bug556174.bugzilla.mozilla.org/attachment.cgi?id=448663

Comment 5

7 years ago
I think we'll need the UX team to comment on this. I don't think the background of the menu was meant to be what they actually looked like.
The mockups for the appearance aren't final yet.  The overall premise of this bug is correct though, in that we will want to use a custom panel instead of a native menu for the contents.  Sub-menus will be native though.  Let's hold off until after beta 1.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

7 years ago
Created attachment 454491 [details]
mockup

Updated

7 years ago
Attachment #454491 - Attachment description: note that the menu background's white and not gray → mockup
(Reporter)

Updated

7 years ago
Summary: [Windows] Change graphical appereance of Firefox Menu to match mockups → [Windows] Change graphical appearance of Firefox Menu to match mockups
>note that the menu background's white and not gray

that's actually a really unfinished mockup.  I'll post a new one after Beta 1.
(Reporter)

Comment 9

7 years ago
What is the reason for using system's styling for submenus?

Comment 10

7 years ago
(In reply to comment #9)
> What is the reason for using system's styling for submenus?

Stupid question. What reason for not using system styling at all?
"system sytlying" could mean two different things:

1) what windows allows us to extract and display through APIs (often this now more functionally ends up meaning "legacy styling")

2) matching the way that other prominent applications appear on the platform (but having to do so with our own custom drawing)

I'm assuming you mean "that's a stupid question, why are you not doing 1" and the answer is that for Vista and 7, #2 actually makes more sense in context.  It's still "native" just not extracted.
(Reporter)

Comment 12

7 years ago
OK, let mi rephrase the question: Why not every menu will be using new graphical appereance? Alex said that only main menu will be using it.

Comment 13

7 years ago
(In reply to comment #12)

That menu will require special functionalities and styling, whereas the sub-menus will not.
(Reporter)

Updated

7 years ago
Keywords: meta
OS: Windows 7 → All
Hardware: x86 → All
Summary: [Windows] Change graphical appearance of Firefox Menu to match mockups → [Meta] Change graphical appearance of Firefox Menu to match mockups
Version: unspecified → Trunk
(Reporter)

Updated

7 years ago
Depends on: 580738
(Reporter)

Updated

7 years ago
Depends on: 580736
(Reporter)

Updated

7 years ago
Depends on: 580740
(Reporter)

Updated

7 years ago
Depends on: 580742
(Reporter)

Updated

7 years ago
Depends on: 580741
Is it true that Firefox Menu is not going to be in Mac Firefox and Linux Firefox at all? Not making them the default option is one thing but removing them altogether seems to make Windows Firefox a entirely different from Mac and Linux Firefox.  

Will the menu and sub-menu look the same?
(Reporter)

Comment 15

7 years ago
Mac will not have Firefox Button, but Linux yes despite the fact that Dao says otherwise.
We are hoping to make it at least an option on every platform, but that work will come later after we have the initial theme work done.
No longer depends on: 580740
I'm duping this change forward to bug 583386 so that we can centralize
discussion, work, and blocking status for beta 4.

That bug has the most up to date mockups for Windows 7.  I've confirmed the XP
and Classic dependent bugs and set them to block the main project.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 583386
(Reporter)

Comment 18

7 years ago
What about Mac and Linux stylings?
You need to log in before you can comment on or make changes to this bug.