Closed Bug 573360 Opened 10 years ago Closed 9 years ago

qute theme: tabbar background blocks lightweight theme image (with personas add-on not enabled)

Categories

(Thunderbird :: Theme, defect, trivial)

x86
Windows XP
defect
Not set
trivial

Tracking

(blocking-thunderbird5.0 -, thunderbird6+ fixed)

RESOLVED FIXED
Thunderbird 7.0
Tracking Status
blocking-thunderbird5.0 --- -
thunderbird6 + fixed

People

(Reporter: gekacheka, Assigned: Paenglab)

Details

(Keywords: polish)

Attachments

(5 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2.4) Gecko/20100608 Lightning/1.0b2pre Thunderbird/3.1

Tabbar background is not transparent so lightweight theme does not show through if Personas Plus add-on is not enabled.

Reproducible: Always

Steps to Reproduce:
1. Add PersonasPlus add on (needed to set lightweight theme, not display it)
   Tools / Addons / Get Add-ons
   Search for "Personas Plus"
   Should appear in list, click its "Add to thunderbird...",
     then click "Install now", then click "Restart Thunderbird"
2. Load a persona/lightweight-theme.  (If new, will default to "Groovy blue" persona, otherwise click fox mask icon in lower left corner and select a persona.  Persona image now displays in tabbar because of personas plus add-on.)
3. Disable the Personas Plus add-on (maybe to remove the firefox mask icon, while keeping the selected persona as a lightweight theme).
Actual Results:  
Tabbar background is opaque light gray.  The theme image does not show through.

Expected Results:  
Tabbar background is transparent.  The theme image shows through.
Overrides both background color and background image.
Attachment #452571 - Flags: review?(bugzilla)
Keywords: polish
Attachment #452571 - Flags: review?(bugzilla) → review?(nisses.mail)
I'm seeing the image on my system now, but for some reason the background don't shine trough. Not sure exactly what is going on.
Comment on attachment 452571 [details] [diff] [review]
patch v1: make tabbar transparent if using a lightweight theme (in qute theme)

As I can't get this patch to work with the expected results on my system, I'll have to set r- on this :(
If others have success in getting this to work, let me know.
Attachment #452571 - Flags: review?(nisses.mail) → review-
(In reply to comment #5)
> As I can't get this patch to work with the expected results on my system, I'll
> have to set r- on this :(
For future reference, could you paste the build id of the build you tested with, and what desktop theme the OS was using (I can't tell what might be different).
Thanks.
Mass move to the new theme component.
Component: Toolbars and Tabs → Theme
QA Contact: toolbars-tabs → theme
Attached patch Updated patchSplinter Review
Updated patch to latest version.

This works by me in conjunction with patch from Bug 573352
Assignee: nobody → richard.marti
Attachment #452571 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #529438 - Flags: review?(nisses.mail)
Comment on attachment 529438 [details] [diff] [review]
Updated patch

Should this go to TB5.0? With personas enabled, this would be a issue on support.
Attachment #529438 - Flags: approval-thunderbird5.0?
blocking-thunderbird5.0: --- → ?
Some remarks.
1. I was unable to discover personas from within Thunderbird; how on earth am I supposed to find them? The addons manager took me to the "themes" section of AMO, and there's only themes there, not personas. I had to fire up the error console to open a new content tab myself pointing to "https://www.getpersonas.com". This is weird.
2. I edited my omni.jar directly with vim, and I had three tabmail.css files:
- chrome/classic/skin/classic/messenger/tabmail.css
- chrome/messenger/content/messenger/tabmail.css
- chrome/classic/skin/classic/aero/messenger/tabmail.css

The first one is the right one. The second one is unrelated stuff, probably common to all themes. The third one has the same contents as the first one, but changing it has no effect... took me a while to figure that out :-(.

3. The patch itself is wrong. Since line 42 assigns !important to both the background-image and the background-color, you need to use !important also if you want your CSS rules to be taken into account.

4. I did use !important, and then, it works as expected. Uploading screenshots...
Comment on attachment 529438 [details] [diff] [review]
Updated patch

Please reupload a new patch, this one doesn't work in my case, and re-ask approval. The patch is right in the essence, though, and you're almost there. Thanks for helping us polish Thunderbird! This does look nicer with the right patch applied :-).
Attachment #529438 - Flags: review?(nisses.mail) → review-
It looks like Bug 573352 wasn't checked in for TB5. This bug corrects the image path and removes the !important.

What should I do? A special patch for TB5 or could Bug 573352 be checked in for TB5?
I think the TB5 train has left the station already, but there's still time to get it into TB6…

(It's a small change, yes, but it's also something that doesn't actually break anything, and only affects people who are still on Windows XP, which is a small percentage of our userbase, so I feel it's not worth the risk of trying to force it into TB5.  Particularly since TB6 will be rolling out real soon now, and we can get it into that.)

Thanks,
Blake.
We've decided not to block on this, as the amount of persona users and those on XP are likely to be small, and it doesn't warrant a respin on its own. We'll be happy to take a fix for TB 6 that resolves this (and will then be released about 6-7 weeks after TB 5).
blocking-thunderbird5.0: ? → -
Attachment #529438 - Flags: approval-thunderbird5.0? → approval-thunderbird5.0-
Comment on attachment 529438 [details] [diff] [review]
Updated patch

Protz: does this need re-review in light of Richard's comments?
Attachment #529438 - Flags: review- → review?(jonathan.protzenko)
Well if it's not to be checked-in on 5.0 and bug 573352 has landed on 6.0, then the first patch is fine, as long as the author checks that it does work fine on 6.0 without the !important. Target milestone = 3.4 for bug 573352, does that mean it's been checked-in for 6.0?
According to http://hg.mozilla.org/releases/comm-aurora/file/81aa6615798a/mail/themes/qute/mail/tabmail.css it's checked-in.

I tried it with today's Earlybird (6.0) and it works.
Attachment #529438 - Flags: approval-comm-aurora?
(In reply to comment #18)
> Target milestone = 3.4 for bug 573352,
> does that mean it's been checked-in for 6.0?

The history says TM 3.4, but the actual milestone says 6.0.
Comment on attachment 529438 [details] [diff] [review]
Updated patch

Sorry if my previous comments were unclear. This is a r+ if landing on 6.0 and not 5.0.
Attachment #529438 - Flags: review?(jonathan.protzenko) → review+
http://hg.mozilla.org/comm-central/rev/092c812854b8
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 7.0
Attachment #529438 - Flags: approval-comm-aurora? → approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.