[D2D] Page Content and Chrome Flickering with D2D Enabled

RESOLVED DUPLICATE of bug 574599

Status

()

Core
Graphics
--
blocker
RESOLVED DUPLICATE of bug 574599
8 years ago
3 years ago

People

(Reporter: sciguyryan, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
The builds after http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-win32/1277431020/ are unusable due to the content and chrome flickering when the page is loading.

I haven't tracked down a regression range but the last bug change was this Bug 513162. If anyone has a regression range please post it here.
Confirmed. Page goes black and it turn to normal all the time.
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Confirmed. Page goes black and it turn to normal all the time.

Yes. That's exactly what happens here.

Comment 3

8 years ago
Confirmed. 

Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a6pre) Gecko/20100623 Minefield/3.7a6pre - Build ID: 20100624140418

Updated

8 years ago
Duplicate of this bug: 574644
Keywords: regressionwindow-wanted
Is this only with D2D enabled? Is that enabled by default?
blocking2.0: --- → ?

Comment 6

8 years ago
(In reply to comment #5)
> Is this only with D2D enabled? Is that enabled by default?
No. I don't think it will be for a while.
(In reply to comment #5)
> Is this only with D2D enabled? Is that enabled by default?

This is only with D2D and it is not enabled by default, so I am not at all sure critical is the correct severity.  Actually, I could make a better case for it being blocker severity as it kind of really puts a halt to testing D2D than I could for critical.

This should probably not be a blocker for 1.9.3 either, but should probably instead block the bug to enable D2D by default.
(Reporter)

Comment 8

8 years ago
It's pretty critical since a lot of nightly testers are using D2D for testing also. That is the whole point of software testers after all - if nobody is able to test it, the feature will never get work correctly.

Comment 9

8 years ago
No Problems:  522df66198cf

Big Problems: 51bd519736c4
(Reporter)

Comment 10

8 years ago
Seems pretty certain that it is a regression from Bug 513162 then.
Blocks: 513162
No longer depends on: 513162
(In reply to comment #6)
> (In reply to comment #5)
> > Is this only with D2D enabled? Is that enabled by default?
> No. I don't think it will be for a while.

Actually, it will be pretty soon.
(In reply to comment #7)
> (In reply to comment #5)
> > Is this only with D2D enabled? Is that enabled by default?
> 
> This is only with D2D and it is not enabled by default, so I am not at all sure
> critical is the correct severity.  Actually, I could make a better case for it
> being blocker severity as it kind of really puts a halt to testing D2D than I
> could for critical.
> 
> This should probably not be a blocker for 1.9.3 either, but should probably
> instead block the bug to enable D2D by default.
It is pretty bad, because we're planning to enable D2D by default on all DX10 hardware before the end of the quarter.
Duplicate of this bug: 574704

Comment 14

8 years ago
I'm not entirely certain but it also looks like cleartype isn't functioning on the flickering content - could be related to Bug 568495
(In reply to comment #10)
> Seems pretty certain that it is a regression from Bug 513162 then.

I verified it is definitely 513162 using hg bisect.
This begs up the question.  Should there be a windows test box running with d2d enabled? And would that even really make sense given that we are really not looking at what is displayed, I have no idea if it would have even caught this.
(In reply to comment #12)
> (In reply to comment #7)
> > (In reply to comment #5)
> > > Is this only with D2D enabled? Is that enabled by default?
> > 
> > This is only with D2D and it is not enabled by default, so I am not at all sure
> > critical is the correct severity.  Actually, I could make a better case for it
> > being blocker severity as it kind of really puts a halt to testing D2D than I
> > could for critical.
> > 
> > This should probably not be a blocker for 1.9.3 either, but should probably
> > instead block the bug to enable D2D by default.
> It is pretty bad, because we're planning to enable D2D by default on all DX10
> hardware before the end of the quarter.

I was not trying to say it was not bad.  Just that given that it is not enabled by default, critical is not really justified, but that given that it blocks development of D2D blocker,which is actually a higher severity IS jsutified.

->> BLOCKER
Severity: critical → blocker
Blocks: 549116
(In reply to comment #16)
> This begs up the question.  Should there be a windows test box running with d2d
> enabled? And would that even really make sense given that we are really not
> looking at what is displayed, I have no idea if it would have even caught this.

It's all being worked on! And it's actually even a blocker for enabling D2D by default, so hopefully we'll have it soon! Bug 549120
Bas, can this be fixed by next nightly? (626 build) I'm asking this because we're cut off from Direct2D by this bug.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 574599

Updated

8 years ago
blocking2.0: ? → ---
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.