Fix Page Info tab highlighting in Windows theme

RESOLVED FIXED in Firefox 4.0b2

Status

()

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: vladmaniac, Assigned: mozilla.bugs)

Tracking

({regression})

Trunk
Firefox 4.0b2
x86
Windows Vista
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a6pre) Gecko/20100625 Minefield/3.7a6pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a6pre) Gecko/20100625 Minefield/3.7a6pre

Selected tab in "Page Info" Menu should change color (appear as highlighted on MouseOver() event). 

Reproducible: Always

Steps to Reproduce:
1. Open any web page in the URL bar. (e.g. www.yahoo.com)
2. Navigate Tools → Page Info





Actual Results:  
Menu Items are static for Page Info while active for other Menu's (e.g. Bookmark Manager). No feedback provided for performing button events. 

Expected Results:  
Inspect the Main Menu Icons. When performing button actions e.g. mouse click, mouse over, selection, etc. button should react with feedback (be highlighted)
Created attachment 454722 [details]
Screen shot of the lack of highlighting

As well as not showing a highlight colour when mousing over one of the icons, the currently selected one isn't highlighted either.  (In the screenshot, the selected icon is "Media", and my mouse pointer was over the "Permissions" icon.)
(Assignee)

Updated

8 years ago
Severity: trivial → enhancement
Status: UNCONFIRMED → NEW
Component: General → Page Info
Ever confirmed: true
QA Contact: general → page.info
Version: unspecified → Trunk

Comment 2

8 years ago
This is a regression from Firefox 3.6.6.

Comment 3

8 years ago
Could anyone please add "regression" (with no quotes) to keywords? Can't do that myself.

Updated

8 years ago
Keywords: regression
(Assignee)

Comment 4

8 years ago
I don't know how we broke it, but I will see if I can find out.
Keywords: regressionwindow-wanted
(Assignee)

Updated

8 years ago
Severity: enhancement → normal
OS: Windows 7 → Windows Vista
(Assignee)

Updated

8 years ago
Keywords: regressionwindow-wanted
(Assignee)

Comment 5

8 years ago
We're missing "#viewGroup > radio[selected="true"]" in our css file, which extensions.css had, but it was removed by Bug 560602 in http://hg.mozilla.org/mozilla-central/rev/2dcd870f9e31.

I'll try to fix this as quickly as possible.
Assignee: nobody → mozilla.bugs
Status: NEW → ASSIGNED
(Assignee)

Updated

8 years ago
Blocks: 560602
(Assignee)

Comment 6

8 years ago
Is this a problem on any other OS than windows?
(Assignee)

Comment 7

8 years ago
Created attachment 455390 [details] [diff] [review]
Patch v. 1.0

This should fix it on the Windows theme, but if it is broken on other OSes, we will need to fix their skins, too.
Attachment #455390 - Flags: review?(db48x)
(Assignee)

Updated

8 years ago
Duplicate of this bug: 576144
(Reporter)

Comment 9

8 years ago
Hi all, I confirm it's a problem only for the windows themes. I've checked also Mac Snow Leopard(32-b) and Ubuntu 10.04(64-b).
OS: Windows Vista → Windows 7
Comment on attachment 455390 [details] [diff] [review]
Patch v. 1.0

Yea, good catch. r=db48x
Attachment #455390 - Flags: review?(db48x) → review+
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
Comment on attachment 455390 [details] [diff] [review]
Patch v. 1.0

> #viewGroup > radio {
>   list-style-image: url("chrome://browser/skin/pageInfo.png");
>   -moz-box-orient: vertical;
>   -moz-box-align: center;
>   -moz-appearance: none;
>   padding: 5px 3px 1px 3px;
>+  margin: 0px 1px 0px 1px;

margin: 0 1px;

>+  min-width: 4.5em;
>+}
>+
>+#viewGroup > radio:hover {
>+	background-color: #E0E8F6;
>+	color: black;
>+}

fix indentation

Updated

8 years ago
Keywords: checkin-needed
(Assignee)

Comment 12

8 years ago
Created attachment 455469 [details] [diff] [review]
Patch v. 1.1

Fixed.
Attachment #455390 - Attachment is obsolete: true
Attachment #455469 - Flags: review?(dao)
Comment on attachment 455469 [details] [diff] [review]
Patch v. 1.1

I was going to say this doesn't need another review, but here's another nit:

> #viewGroup > radio {
>   list-style-image: url("chrome://browser/skin/pageInfo.png");
>   -moz-box-orient: vertical;
>   -moz-box-align: center;
>   -moz-appearance: none;
>   padding: 5px 3px 1px 3px;
>+  margin: 0px 1px;

s/0px/0/
Attachment #455469 - Flags: review?(dao)
(Assignee)

Comment 14

8 years ago
Created attachment 455499 [details] [diff] [review]
Patch v. 1.2

Fixed and ready for landing.
Attachment #455469 - Attachment is obsolete: true
(Assignee)

Updated

8 years ago
Keywords: checkin-needed

Comment 15

8 years ago
I can reproduce this bug on Mac OS.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1
(Assignee)

Comment 16

8 years ago
I am filing a separate bug for the Mac issue, since I don't have a Mac development environment; I can generate patches, but I can't test them (that I'm aware).  So I am limiting this bug to Windows Page Info issues regressed by the removal of the old extensions manager.
OS: Windows 7 → Windows Vista
Summary: Highlight selected tab in "Page Info" → Fix Page Info tab highlighting in Windows theme
(Assignee)

Comment 17

8 years ago
I have filed Bug 576586 for Mac css issues.
http://hg.mozilla.org/mozilla-central/rev/49dec7e8ec3f
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7b2
You need to log in before you can comment on or make changes to this bug.