changing system theme/screen resolution and/or previewing personas causes tabs-on-top to switch to tabs-on-bottom

RESOLVED DUPLICATE of bug 555987

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 555987
8 years ago
8 years ago

People

(Reporter: [not reading bugmail], Unassigned)

Tracking

unspecified
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 beta1+)

Details

(Whiteboard: [to be fixed by bug 555987], URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a6pre) Gecko/20100623 Minefield/3.7a6pre Firefox/3.6.4
Build Identifier: 

Tabs position breaks when adding a persona.



Reproducible: Always

Steps to Reproduce:
Steps to Reproduce:
1.Using latest nightly
2.use default theme
3.Open Get Personas
4.Preview Lw theme.
Actual Results:  
Tabs get moved to bottom.

Expected Results:  
Tabs should have stayed on top.


The problem is "fixed" if you check/uncheck the tabs-on-top option twice. This
looks like a regression from bug 571992.

Last working changeset:
Thu Jun 24 09:34:21 2010 -0700
http://hg.mozilla.org/mozilla-central/rev/5edea2cbbcb0
(Reporter)

Comment 1

8 years ago
Ignore my build id here as the bug would have been seen after the changeset occurred.
Blocks: 571992
(Reporter)

Comment 2

8 years ago
It looks like the gradient is also gone.

Comment 3

8 years ago
duplicate from https://bugzilla.mozilla.org/show_bug.cgi?id=574593 ?
(although your issue is different, this is a regression from https://bugzilla.mozilla.org/show_bug.cgi?id=571992 so they are most likely caused by the same patch).
(Reporter)

Comment 4

8 years ago
Created attachment 454106 [details]
Tabs moved to bottom after going after previewing a persona

I filed it because this was personas, I almost commented on the other bug.. but just wanted to make sure I guess if the underlining code was different, to have it separate.

This is what I see after bug 513162 landed after the switch to tab bug.
(Reporter)

Comment 5

8 years ago
Note I didn't apply a persona, I just previewed it.
probably another -moz-box-ordinal-group bug
Component: General → Style System (CSS)
Product: Firefox → Core
QA Contact: general → style-system

Updated

8 years ago
Duplicate of this bug: 574440

Updated

8 years ago
Duplicate of this bug: 574593
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?

Updated

8 years ago
Blocks: 574833
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Tabs-on-top change to tabs-on-bottom if going from default theme to persona → changing system theme/screen resolution and/or previewing personas causes tabs-on-top to switch to tabs-on-bottom
(Reporter)

Comment 9

8 years ago
I guess this also happens when switching personas in the addon manager if you have tabs on top, it goes to the bottom.
(Reporter)

Comment 10

8 years ago
System theme changes between Aero themes and non-Aero themes with having tabs on top setup properly, will cause tabs on top to switch.  

However, it does not occur changing from one system Aero theme to another.
This seems to be Aero theme only.  I can not reproduce this under Windows/XP.
Dao, patch incoming?
blocking2.0: ? → beta1+
Depends on: 555987
Oh, this is deeper than just CSS styling, it's something in the core. CC'ing some relevant folks who might be able to help.

This is a pretty visible bug on trunk these days, and blocking the first beta.
Should the discussion of the core bug stay in bug 555987, or is this somehow different?  (Does one of the Neils know the relevant bits of nsBoxFrame?)
If this is the same, it can happen in bug 555987, I suppose. Do we expect the fix there will resolve this one, as well?

Updated

8 years ago
Duplicate of this bug: 575290
This worksforme on Linux.  Is this Windows-only?

Comment 18

8 years ago
(In reply to comment #17)
It is, yes.
The patch in bug 555987 fixes this.
Whiteboard: [to be fixed by bug 555987]
Gonna dupe this off to 555987, undupe if it wasn't fixed.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 555987
(Reporter)

Updated

8 years ago
No longer blocks: 574833
You need to log in before you can comment on or make changes to this bug.