Last Comment Bug 575270 - Give @localizers SVN access to Marcos
: Give @localizers SVN access to Marcos
Status: RESOLVED FIXED
:
Product: mozilla.org
Classification: Other
Component: Repository Account Requests (show other bugs)
: other
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Shyam Mani [:fox2mike]
:
:
Mentors:
Depends on: 587640
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-28 07:52 PDT by Pascal Chevrel:pascalc
Modified: 2010-08-16 07:18 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Pascal Chevrel:pascalc 2010-06-28 07:52:38 PDT
Marcos our Asturian localizers needs his LDAP account to be granted SVN as part of our @localizers group

Marcos already has HG access and provided a signed Committer's agreement (see https://bugzilla.mozilla.org/show_bug.cgi?id=549934)

His LDAP account is: maacub@gmail.com

Thanks
Comment 1 Marcia Knous [:marcia - use ni] 2010-06-28 09:48:27 PDT
Over to server ops for addition to @localizers group.
Comment 2 Shyam Mani [:fox2mike] 2010-06-28 10:18:53 PDT
Done.
Comment 3 Pascal Chevrel:pascalc 2010-08-13 07:07:28 PDT
Reopening, Marcos has not been able to commit so far, here is the errors he is receiving:

svn commit prueba.txt -m "l10n: ast testing commit rights"
Authentication realm: <https://svn.mozilla.org:443> Mozilla LDAP
Password for 'marcos':
Authentication realm: <https://svn.mozilla.org:443> Mozilla LDAP
Username: maacub@gmail.com
Password for 'maacub@gmail.com':
Authentication realm: <https://svn.mozilla.org:443> Mozilla LDAP
Username: maacub@gmail.com
Password for 'maacub@gmail.com':
svn: Commit failed (details follow):
svn: MKACTIVITY of '/!svn/act/8cfa52c6-44cb-4d67-b640-ef950bf4337c': authorization failed: Could not authenticate to server: rejected Basic challenge (https://svn.mozilla.org)
Comment 4 Shyam Mani [:fox2mike] 2010-08-16 01:59:39 PDT
Forgot to flip the relevant svn_ bits, which I've done now. Should work fine.
Comment 5 marquinos 2010-08-16 04:50:29 PDT
Hi! Now appears works the login, but not the permissions :)
http://pastebin.mozilla.org/769026
Could you review it, please?
Thanks very much!
Comment 6 Shyam Mani [:fox2mike] 2010-08-16 05:58:31 PDT
That's because @localizers don't have commit access to mozilla.com/trunk

svn: Server sent unexpected return value (403 Forbidden) in response to CHECKOUT request for '/!svn/ver/69728/projects/mozilla.com/trunk/ast/includes/l10n/main.lang'

That's why the error above.
Comment 7 Pascal Chevrel:pascalc 2010-08-16 06:11:27 PDT
shyam, all localizers have access to mozilla.com/trunk/LOCALECODE/ but I believe the problem is that ast is a brand new locale (we will release it for the first time with 3.6.9) so trunk/ast/ should be added to the folders localizers have access to (as well as hy-AM and gd which are also new locales that should be released next quarter). Can you add /ast/, /gd/ and /hy-AM/ to the properties @localizers have access to or do you want me to file a separate bug?
Comment 8 Shyam Mani [:fox2mike] 2010-08-16 06:22:22 PDT
Pascal,

A new bug would be better :) Thanks! If you want to you can make that block this bug so once that's fixed, Marcos should have access.

Note You need to log in before you can comment on or make changes to this bug.