If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Tabs disappearing on app close to dock [Mac]

RESOLVED FIXED

Status

Thunderbird
Toolbars and Tabs
--
major
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: jan, Unassigned)

Tracking

x86_64
Mac OS X

Thunderbird Tracking Flags

(thunderbird3.1 .3-fixed)

Details

(Whiteboard: [gs][fixed by bug 575864], URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-GB; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; it; rv:1.9.2.4) Gecko/20100608 Thunderbird/3.1

Messages opened as tabs, do not keep open at next opening of Thunderbird. 
It's quite annoying, especially as I use to keep messages in tabs when they're important and I need to access them quickly...

Reproducible: Sometimes
(Reporter)

Updated

7 years ago
Version: unspecified → 3.1
(Reporter)

Comment 1

7 years ago
I discovered that it happens each time I close the application window (I do not mean "the application" = Cmd+W not Cmd+Q) :(
Whiteboard: dupme

Comment 2

7 years ago
After upgrading to 3.1.2 yesterday, all tabs but one are consistently lost when
the Mail&Newsgroups window is closed and re-opened, or the application is closed
and re-started.  I believe I've seen it with earlier versions, but now it's
particularly noticeable because of bug #579848 (No folders or message list shown when staring in 'Unified Folders' view)...

Comment 3

7 years ago
Same thing happening here on Mac OS 10.6. All tabs except mailbox tab close when application is "minimized" to dock.
ludo, roland, can you reproduce on Mac?  Also, I'm pretty sure there is a fairly new item on gfsn about this, or closely related

Henrik, Bug 579848 is not fixed in v3.1.2

Comment 5

7 years ago
Mine is the same as Bob's, when I close to dock I lose all my tabs.
can someone say this is a regression in 3.1?

confirming based on multiple reports. 
http://forums.mozillazine.org/viewtopic.php?f=39&t=1966109
http://gsfn.us/t/1bbyv and http://gsfn.us/t/19lxb
If there is another bug on this I couldn't find it, so removing dupme

I'll be merging bob's gsfn http://gsfn.us/t/19lxb to http://gsfn.us/t/1bbyv but I can't seem to do so right now, gsfn claims http://gsfn.us/t/1bbyv "URL does not point to a valid topic"
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Tabs disappearing on app close → Tabs disappearing on app close to dock [Mac]
Whiteboard: dupme → [gs]
Duplicate of this bug: 588765

Comment 8

7 years ago
Same here. I have three tabs open at all time. One for work mail. One for Gmail and one for Lightning. I have Message Pane disabled.

When closing (on red x) but app still running, opening again all tabs are gone and first tab is Inbox (work mail) and Message Pane is enabled.

Thunderbird 3.1.2
Mac OSX 10.6.4 

Didn't have this problem before updating.

Comment 9

7 years ago
(In reply to comment #8)
> When closing (on red x) but app still running, opening again all tabs are gone
> and first tab is Inbox (work mail) and Message Pane is enabled.

Message Pane problem is Bug 575864.

Comment 10

7 years ago
(In reply to comment #9)
> (In reply to comment #8)
> > When closing (on red x) but app still running, opening again all tabs are gone
> > and first tab is Inbox (work mail) and Message Pane is enabled.
> 
> Message Pane problem is Bug 575864.

Thanks. Now I got two problems.. :)

Comment 11

7 years ago
I updgraded to 3.1.3 today. Problem seems to be solved.
(Reporter)

Comment 12

7 years ago
Yes not it's solved. Perfect!! Thank you very much :)
Thanks for the confirmations, marking as fixed by bug 575864 as that would be what fixed it.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
status-thunderbird3.1: --- → .3-fixed
Depends on: 575864
Resolution: --- → FIXED
Whiteboard: [gs] → [gs][fixed by bug 575864]
You need to log in before you can comment on or make changes to this bug.