browser ignoring tabMinWidth and tabClipWidth

RESOLVED INVALID

Status

()

Firefox
Tabbed Browser
RESOLVED INVALID
8 years ago
a year ago

People

(Reporter: randomemail, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; en-US; rv:2.0b2pre) Gecko/20100708 Minefield/4.0b2pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; en-US; rv:2.0b2pre) Gecko/20100708 Minefield/4.0b2pre

First noticed with the nightly build for June 5th.  In about:config, browser.tabs.tabClipWidth and browser.tabs.tabMinWidth settings have no impact on the width of the tabs.  Have tried different values to the same effect (after restarting the browser).

Reproducible: Always

Steps to Reproduce:
1. Use about:config to change the values of browser.tabs.tabClipWidth and browser.tabs.tabMinWidth
2. See that the tabs don't change their width.
3. Profit.
Actual Results:  
Nothing, which is the problem.  The tabs don't resize.

Expected Results:  
Up to and including the nightly build for June 4th, the tabs would resize based on the settings in browser.tabs.tabClipWidth and browser.tabs.tabMinWidth.

I typically have browser.tabs.tabClipWidth and browser.tabs.tabMinWidth set to 20 and 18 respectively (I normally have a large number of tabs open, and immediately noticed that the tabs weren't shrinking down to the size I'd set).
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk
Related to bug 574654 probably.
tabClipWidth should be working. Instead of tabMinWidth, try setting this in userChrome.css:

.tabbrowser-tab[fadein]:not([pinned]) {
  min-width: 18px !important;
}
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

8 years ago
The work-around works, but the about:config setting still may need to be fixed/deactivated.  (It's also simpler than fishing out the userchrome file and editing that.)
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
browser.tabs.tabMinWidth isn't supported anymore.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INVALID
re: comment 4 sorry I didn't got that memo :) can you please point me to the bug, mailing list thread or wiki page were this useful preference got killed? Thanks!

Comment 7

8 years ago
(In reply to comment #6)
> can you please point me to the bug, mailing list thread or wiki page were this > useful preference got killed?
> Thanks!

Bug 574654

Updated

8 years ago
Duplicate of this bug: 582930
Duplicate of this bug: 583562
Bug 574654 justifies the removal of that useful preferences used by many and documented in several places as an alternative to the annoying tabscroll with:

"I don't think the prefs are worth it"

This IMHO was a rush decision, not well informed and not based on evidence. Can someone please reconsider that, reopen this bug and maybe revert that patch?
Duplicate of this bug: 583712
Duplicate of this bug: 590852

Comment 13

8 years ago
I agree with Fabricio. These options are the only way to make the tabs in Firefox 3 or later behave like in Firefox 2. Personally, I find the way tabs work in Firefox 3 to be completely unintuitive and unusable (having to click 3 times to select a tab is stupid), and I am sure many users think the same way (have a look here for instance this http://input.mozilla.com/en-US/search/?q=tabMinWidth&product=firefox). Also personally, I think this option should be made *more prominent*, for instance by allowing it to be set from the preferences, instead of hiding it deeper and deeper until nobody can find it any more and they all switch to Chrome, which offers proper tab behavior as the default not through options hidden in some CSS file.

Comment 14

8 years ago
A small correction, Fabricio is right (https://bugzilla.mozilla.org/show_bug.cgi?id=574654#c23) it was Firefox 2 that introduced the horrible hidden tabs + tabscroll as a default. Firefox 1.6 was the last version in which tabs would scale down by default. Can users have an *easy* way to get back to the 1.6 tab behavior?
Yeah, I also agree, that starting with FF4 handling many tabs became really annoying, and no Panorama can ever fix this for me (and obviously many other people as one can see in this thread and the tons of duplicate bugs). I also agree that a simple "Use tab scrolling if too many tabs" option should rather be more prominent in the GUI than put done in a .css file.

Comment 16

7 years ago
I signed up for this just to complain.  I am a relatively sophisticated user, and *I* have trouble with the css files.  Tab width is *definitely* important to me, and having a simple, consistent way of reducing the minimum tab width is not a trivial thing for me.

PLEASE do not force us to learn css in order to do simple customization of firefox.

Comment 17

a year ago
I know this is really old, but if anyone comes to this page looking for a way to change the tab widths, this addon should help: https://addons.mozilla.org/en-US/firefox/addon/custom-tab-width/
You need to log in before you can comment on or make changes to this bug.