{feature} CSS First-letter selector isn't finished

VERIFIED FIXED in M6

Status

()

Core
CSS Parsing and Computation
P5
enhancement
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: Angus Davis, Assigned: buster)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
See URL given for sample HTML and test case. Again (similar to 311767) I expect
we don't have the api yet in the content model, but ultimately it's a style
thing.

Updated

20 years ago
Status: NEW → ASSIGNED
Component: Unknown → Style System

Updated

20 years ago
Priority: P2 → P3

Comment 1

20 years ago
This is now partially implemented

Comment 2

20 years ago
*** Bug 1509 has been marked as a duplicate of this bug. ***

Comment 3

20 years ago
*** Bug 1518 has been marked as a duplicate of this bug. ***

Comment 4

20 years ago
*** Bug 1932 has been marked as a duplicate of this bug. ***

Comment 5

20 years ago
*** Bug 1985 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Summary: CSS First-letter selector doesn't work → CSS First-letter selector isn't finished

Comment 6

20 years ago
Setting all current Open/Normal to M4.

Comment 7

20 years ago
See bww-firstletter.html for a nastier test that demonstrates that the style
context ordering is wrong.

Updated

20 years ago
Severity: normal → enhancement
Priority: P3 → P5

Comment 8

20 years ago
*** Bug 1931 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Summary: CSS First-letter selector isn't finished → {feature} CSS First-letter selector isn't finished

Comment 9

19 years ago
We now pass the mentioned test.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
Using 4/30 Apprunner, first-letter selector works correctly. Verifying bug
fixed.
You need to log in before you can comment on or make changes to this bug.