Backround of Adblock Plus context-menu is Transparent

RESOLVED INVALID

Status

()

Toolkit
Themes
--
trivial
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Stefan Kelemen, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b3pre) Gecko/20100727 Minefield/4.0b3pre
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b3pre) Gecko/20100727 Minefield/4.0b3pre

There is no Backround at Adblock Icon. Text is Right, Backround failed.
In Version 3.5 and 3.6 are the Backround with same Plugin are korrekt.

Reproducible: Always

Steps to Reproduce:
1.Rightclick on adblock Icon on the right side
2.
3.
Can you please attach a screenshot?
I can confirm this.  Regression happened sometime between 100706 and 100715 nightlies -- tracking down a more precise regression range right now...
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
Version: unspecified → Trunk
Summary: Backround of Adblock are fully Transparent and not normal → Backround of Adblock Plus menu is Transparent
Summary: Backround of Adblock Plus menu is Transparent → Backround of Adblock Plus context-menu is Transparent
Regression range:

Mozilla/5.0 (X11; Linux x86_64; en-US; rv:2.0b2pre) Gecko/20100713 Minefield/4.0b2pre
Mozilla/5.0 (X11; Linux x86_64; en-US; rv:2.0b2pre) Gecko/20100714 Minefield/4.0b2pre
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1a107c990c89&tochange=5355f245b916

Looks like a regression from bug 578322 ("Remove support for <popup> from all themes") -- in fact it was reported on that bug, as bug 578322 comment 4:
> This broke pop-ups from right-click context menus for addons that are in the
> status-bar, i.e. ABP, AniWeather, or any addon that for now works in the
> status-bar.  The context menu shows, but it is 'transparent'.

Based on the comment after that though, it sounds like this is expected.
Keywords: regression
CC'ing Dão, who wrote the patch for bug 578322.

Dão, should this be WONTFIX?  (sounds like it from your last comment on bug 578322)
Blocks: 578322
Component: Menus → Themes
Product: Firefox → Toolkit
QA Contact: menus → themes
Looks like for Firefox Sync, this was as simple as a s/<popup>/<menupopup>/g:
  https://bugzilla.mozilla.org/show_bug.cgi?id=579837
  http://hg.mozilla.org/services/fx-sync/rev/24e32e70f9c9

I imagine Adblock Plus just needs the same change applied.

Comment 7

8 years ago
INVALID
1. Working (or broken) as designed.
2. Extension problem, not Firefox nor Toolkit nor Core.

Please make sure you are using the latest version of Adblock Plus e.g. 1.2.1
<https://addons.mozilla.org/en-US/firefox/addon/1865/versions/>
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(In reply to comment #7)
> Please make sure you are using the latest version of Adblock Plus e.g. 1.2.1
> <https://addons.mozilla.org/en-US/firefox/addon/1865/versions/>

I am already using the latest version, 1.2.1.  Hopefully an upcoming Adblock Plus update will fix this, though.

Comment 9

8 years ago
This is already fixed in the current Adblock Plus development builds - https://adblockplus.org/en/development-builds
So far I'm not sure whether this issue is worth an 1.2.2 release.
Gijs, CZ has this issue as well.

Comment 11

8 years ago
(In reply to comment #10)
> Gijs, CZ has this issue as well.

That's bug 579271 .
Eric: right-click menus from the FoxyProxy (Basic edition, ver 1.7.4) main options dialog have this issue, too. (Its status-bar's context menu is fine, though)
(sorry, meant to CC Eric Jung of foxyproxy w/ prev comment.)
Duplicate of this bug: 592158
Duplicate of this bug: 592573
You need to log in before you can comment on or make changes to this bug.