Closed Bug 583294 Opened 10 years ago Closed 10 years ago

BSOD in WinXP SP3 when using Thunderbird 3.1.1

Categories

(Thunderbird :: General, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED INVALID

People

(Reporter: jon, Unassigned)

References

()

Details

(Whiteboard: [gs])

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 ( .NET CLR 3.5.30729; .NET4.0C)
Build Identifier: 3.1.1

I recently started using Thunderbird 3.1.1 as an update from 3.1.  I had done a fresh install of 3.1 after removing 3.0.  I have one IMAP account for google setup with one google calendar syncing.

After using Thunderbird for a few minutes, I keep getting a BSOD.  I would have thought it was my wireless driver that I updated, but I rolled that driver back and it still happened.  I also ran the crash logs through the WinDbg program and it pointed to Thunderbird for the problem.  There is also a support thread of other people having the same thing on WinXP SP3.  My Samsung-NC10 netbook hasn't had a single BSOD that I remember since I got it in 2008-11, but I had three of them this morning in less than 1 hour using Thunderbird.

Reproducible: Always

Steps to Reproduce:
1.  Start Thuderbird
2.  Use it for awhile (probably syncing my google IMAP in the background)
3.  wait for BSOD
Actual Results:  
BSOD with the DRIVER_IRQL_NOT_LESS_OR_EQUAL error.

Expected Results:  
no BSOD

There is a support thread going with multiple people having this issue.

http://getsatisfaction.com/mozilla_messaging/topics/blue_screen_of_death_after_updating_thunderbird_today_7_21_10?utm_medium=widget&utm_source=widget_mozilla_messaging
Attachment #461590 - Attachment description: Crash Log 1 from WinDbg → Crash 1 log from WinDbg
actually, I just checked again, and I can make this happen.  It seems to trigger after having Thunderbird open for a few minutes, but not right away.  

I also have had Outlook open at the same time.  It may be related somehow.  I will try letting Thunderbird just sit open by itself and see what happens.
Version: unspecified → 3.1
Thunderbird can not cause a Blue Screen, windows freeze or reset because it's a
usermode application. Only the windows kernel/system, hardware problems and in
most cases installed drivers can cause this.
It doesn't matter if you get a bluescreen only with one usermode application or
only with one application version, it's still a bug in those kernelmode
components and the usermode application triggers only the bug.

I would try to upgrade your video card drivers first.


marking invalid because this is not a bug in Thunderbird.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
Well, generally, I agree that a usermode program can't cause a BSOD.  However, it's interacting with system things and if it's sending bad data, the kernel will operate on it.

And MULTIPLE people are seeing this problem, so obviously something is going on.

And saying to update the video driver is useless.  It's a netbook with intel 945 drivers on WinXP.  How many MILLIONS (probably tens of millions) of people are using that same driver?  If suddenly after 3.1.1 comes out and people start having BSODs, it tells me there's a problem somewhere in how Thunderbird is interacting with the XP system.  There is no problem in Vista.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Marking it back to unconfirmed.
Whiteboard: [gs]
sorry but this is invalid and will not be fixed by us. You are complaining at the wrong place.
Use the windows debugging tools to find the driver that is causing your BSOD.
In your Windbg trace you will find this 
"An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high. This is usually caused by drivers using improper addresses."

>However, it's interacting with system things and if it's sending bad data, the 
>kernel will operate on it.

not that it matters but how do you know that it's bad data ? 
You can't send "bad data" because the API would reject it.

We don't have the resources to help every user with their driver problems.
We would probably would add a workaround for driver issues if a high percent of our user would hit this bug. We did that the last time for a windows95/98 nvidia driver bug.
I don't see that we got more reports in the last few weeks about BSODs, only under one report/week and in most cases for Firefox.

marking invalid again
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → INVALID
I'm not looking for any help debugging any driver issues.  The thing that changes is adding Thunderbird into the mix.

And, if you look at the link I provided in the original report, you would find several people experiencing this in the last week.  If several people experience it who 1) use thunderbird, 2) use WinXP, 3) are willing to report and ask about it is a couple, then there are probably many more out there that have the same problems.  It is strange that people are having odd BSOD with corrupt data coming out of Firefox and also with Thunderbird.  If people don't have problems NOT using that software, but magically have problems with one of two pieces of software that share a lot of code, I wager to guess the problem is in the shared bit of code.  

Granted, maybe this is just exposing some deep bug in a driver somewhere, but to just say "sorry, it has to be driver." doesn't seem right either.  In fact, I discovered this issue this morning trying to covert 10+ people to Thunderbird.  I'm definitely reconsidering that recommendation now.

Regarding the bad data, I don't know that it is.  Just saying it could be.  And "bad" data can still make it past API data checks.  And on XP, things aren't as walled off as Vista+/Mac/Linux, so maybe a garbage writer somewhere is crashing the driver.

If you're not going to investigate, then that's fine.
If there is a driver that has a bug that is being triggered by TB, that is entirely possible. But again, there is nothing that we can do about that.
Status: RESOLVED → VERIFIED
Well, there is bug 352694 as a precedence for working around a common driver bug, in that case for a faulty feature in specific graphics cards. However,
the issue there was well defined and localized, whereas the minidumps here aren't conclusive. First it would be good to figure out which driver (or type
of driver) is the cause and why, and if it's possible to avoid it somehow.

I'd suggest to return to the GS thread and figure out what the systems running into the issue have in common, other than running Windows XP SP3, any kind of common hardware, etc. It is certainly suspicious if a dozen reports suddenly show up which happen in 3.1.1 and are resolved by going back to 3.1, so there definitely was some checkin (likely Core would be my guess) which combined with certain hardware/driver causes the issue. If that could be isolated, then some workaround could be found (like the hotfix add-on in the bug I've mentioned).
Admittedly, it's an odd concept and most people understandably don't fathom, that if you add a change in program A (Thunderbird in this case) to the mix, that a support person would say the problem isn't solvable in program A.  However, as I am cited as saying in http://gsfn.us/t/18jb1 the vast majority of BSOD are correctly closed as invalid.

The fact that more than one person reports the problem doesn't fundamentally change the dynamics. The nvidia example cited in comment 5 was an exception, pursued only after probably hundreds of problem reports. Comment 11 is exactly the right way to go at this stage.
The nvidia driver bug affected all nvidia card user on win9x and nvidia cards are very common and the crash happened on every website that resized images in a special way.
The situation on windowsXP is the same as on all NT based system, there is no protection difference compared to linux/OS X/win7.
We get all the time reports about driver bugs. It's not our fault if the driver crashes and adding workarounds is very difficult if you don't have the same hardware and drivers. Our developers would work half of their time with adding workarounds to driver crashes if we would do that. That is just not possible. To give you an example : Many canon printer drivers crashed on OS X if you printed a website with FF and this got only fixed with a new canon driver.

The Windbg stack traces shows nothing interesting for me.
You can only try to either update or downgrade drivers that could cause this.
a) video card b) firewall c) Antivirus c) sound
If you want better results you can configure your system to generate complete dumps instead of minidumps. you can also use the windows driver verifier:

http://support.microsoft.com/kb/244617

the bottom line with any driver fault is: it's the driver vendor's fault, and the driver vendor is responsible for fixing it. if you provide them the dump, they should be willing to investigate.

http://www.google.com/search?q=BugCheck+100000D1%2C+{%2C+2%2C+0%2C+}

has some initial candidates fwiw...
You need to log in before you can comment on or make changes to this bug.