Closed Bug 58332 Opened 20 years ago Closed 19 years ago

Shift+PgDn does nothing

Categories

(Core :: DOM: Editor, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Future

People

(Reporter: fuerte, Assigned: mjudge)

References

Details

(Whiteboard: [keybnd])

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; m18) Gecko/20001027
BuildID:    Gecko/20001027

When I do Shift+PgDn/Up in Editor it does nothing. Also PgDn/Up does not move
the cursor.

Reproducible: Always

Expected Results:  Shoud move the cursor down one page (and scroll the window)
and select the text.
pgup/pgdn not moving caret is a separate bug (#4302)
Until that bug is fixed, the shift version of the keybinding won't work as
expected either.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Depends on: 4302
Ever confirmed: true
Target Milestone: --- → Future
Bug 4302 seems to be fixed for Win32 in my 2001053104 build... Sooo that would 
leave this bug on its own now...

Also, I would say the severity of this should be normal, not enhancement... 
Anyone who uses web-based e-mail regularly probably gets bitten pretty hard by 
this bug... It's one of the few things keeping me from using Mozilla 
regularly... =\
you are absolutely correct, this should not be an enhancement, changing
Severity: enhancement → normal
Keywords: correctness
Whiteboard: [keybnd]
*** Bug 89126 has been marked as a duplicate of this bug. ***
-->kin
note: bug #4302 is *not* fixed
Assignee: beppe → kin
OS: Windows ME → All
Hardware: Other → All
--> mjudge owns selection and selection/caret navigation

Assignee: kin → mjudge
*** Bug 130647 has been marked as a duplicate of this bug. ***
I posted patches to Bug 4302.
They fixes this bug also.
*** Bug 151192 has been marked as a duplicate of this bug. ***
*** Bug 106157 has been marked as a duplicate of this bug. ***
This bug is still present in at least the Win32 builds of Mozilla 1.1b and
nightly build 2002072308.
I am avoiding the bug by shrinking the message header display....I suspect this
is a fundamental U.I. class problem... that couldn't fixed easily... strongly
suggest using abbreviated display I put fowrard here as a temp fix, rather than
fighting with RFC spec requirement....
I think Mike fixed this as part of bug 4302; reopen if there is a problem
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Doesn't work on Linux (RH 7.2).
Shift + PgDn/PgUp does still nothing (in textareas, mail composer, html composer).

The PgDn/PgUp now correctly moves the cursor, so bug 4302 is fixed fine :-)

Please someone test on Windows and other platforms.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
part of the patches for fixing bug 4302 were not checked in; I have now checked
those in so this bug should be fixed with today's builds.  Please reopen if
there is a general problem with this not working.  Thanks!
Status: REOPENED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.