Closing tab group in tab candy should ask for confirmation

RESOLVED DUPLICATE of bug 588526

Status

Firefox Graveyard
Panorama
RESOLVED DUPLICATE of bug 588526
8 years ago
2 years ago

People

(Reporter: Anthony R. Thompson, Unassigned)

Tracking

Trunk
x86
Windows XP

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b3pre) Gecko/20100729 Minefield/4.0b3pre
Build Identifier: Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b3pre) Gecko/20100729 Minefield/4.0b3pre

If you try to close a window in Firefox with multiple tabs, it asks you if you're sure you want to do that so you don't lose a bunch of important tabs with one mis-click.

While initially playing around with tab candy, I was unsure how to deselect the tab group title after giving it a title (it stubbornly remained highlighted even though I clicked elsewhere).

Not knowing how else to deselect the tab group name (thus ending the tab renaming process), I clicked the X on the right and BAM, the entire tab group disappeared - no confirmation or anything.  Very frustrating.

The expected behavior should match the behavior for closing a window with multiple tabs - asking for confirmation.

Reproducible: Always

Steps to Reproduce:
1. Click on tabcandy button ("Open a visual tab interface")
2. Drag one tab out of the main group to start a new tab group
3. Drag another tab from the main group to the new tab group
4. Click the X in the new tab group
Actual Results:  
The tab group closes immediately without asking for confirmation

Expected Results:  
Since there is more than one tab, the browser should ask for confirmation before closing the group.

It would also be nice if it were possible to "undo" closing a tab group in case one mistakenly closed a tab group and then realized it had an important tab in it.  Maybe something like History -> Recently Closed Tab Groups.

(History -> Recently Closed Tabs has certainly saved my butt a number of times!)
Mass moving all Tab Candy bugs from Mozilla Labs to Firefox::Tab Candy.  Filter the bugmail spam with "tabcandymassmove".
Component: TabCandy → TabCandy
Product: Mozilla Labs → Firefox
Target Milestone: -- → ---
Version: unspecified → Trunk

Comment 2

8 years ago
Even worst is if you just have one set.
Closing the only set would actually close the tabs AND Firefox
This is clearly a bug as I had "Warn me when closing multiple tabs" option enabled but I wasn't warned at all =(
http://feedback.mozillalabs.com/forums/56804-tabcandy/suggestions/993999
This should be confirmed AND block.

Comment 3

8 years ago
Duplicate? bug 576427
(In reply to comment #3)
> Duplicate? bug 576427

I don't think so, but closely related
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

8 years ago
agree. we need warnings and a sane selfexplaining way of getting rid of the tabcandy view on the firefox window with multiple tabs

https://bugzilla.mozilla.org/show_bug.cgi?id=588355

:(
thanks.

Updated

8 years ago
QA Contact: tabcandy → tabcandy

Comment 6

8 years ago
Hey guys,

So first apologies for not having an undo feature yet. I know how frustrating losing your work can be. We are working on a fix. In bug 588526.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 588526

Comment 7

8 years ago
As a second note, I haven't been able to duplicate the lack of warning when closing a Firefox window with multiple groups.
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.