Closed Bug 583616 Opened 10 years ago Closed 9 years ago

icons on OS X bookmark toolbar not constrained to 16x16

Categories

(Firefox :: Theme, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 4.0b7
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: Dolske, Assigned: mstange)

References

Details

Attachments

(1 file, 1 obsolete file)

Bug 566034 turned on favicons for the OS X toolbar. Looks like we're not correctly limiting the size to 16x16, see bug 566034 comment 17 - 19.

STR:
1) Add http://www.stanford.edu/ to bookmark toolbar
2) Notice that icon is 16x32.
Attached patch Patch v.1 (obsolete) — Splinter Review
Ick. The obvious change would be to set "max-height: 16px", but then the icons are again squished to 14px tall. The problem is that toolkit/themes/pinstripe/global/toolbarbutton.css sets 1px of top/bottom padding on the icon, so the correct min/max-height is actually 18px.

Probably should change the other CSS to be 1px of margin, or set the padding on the parent element, but I'm a bit loathe to be making/testing that as a broader change. But maybe I should. :(
Assignee: nobody → dolske
Attachment #461967 - Flags: review?(dao)
Or you could just set padding:0 only for this icon.
Comment on attachment 461967 [details] [diff] [review]
Patch v.1

see comment 2
Attachment #461967 - Flags: review?(dao)
blocking2.0: --- → ?
blocking2.0: ? → betaN+
I hit this with Google Reader :(
Attached patch v2Splinter Review
Assignee: dolske → mstange
Attachment #461967 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #475500 - Flags: review?(dao)
Attachment #475500 - Flags: review?(dao) → review+
Whiteboard: [can land]
http://hg.mozilla.org/mozilla-central/rev/55d9426f9a57
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b8
Duplicate of this bug: 606844
Whiteboard: [can land]
Target Milestone: Firefox 4.0b8 → Firefox 4.0b7
Duplicate of this bug: 596801
No longer blocks: 596801
Duplicate of this bug: 594834
You need to log in before you can comment on or make changes to this bug.