Do 32-bit Windows builds on 64-bit Windows

RESOLVED DUPLICATE of bug 709480

Status

P5
enhancement
RESOLVED DUPLICATE of bug 709480
8 years ago
6 months ago

People

(Reporter: khuey, Unassigned)

Tracking

Details

(Whiteboard: [win64])

FWIW, plenty of developers build in this configuration (myself included). I suspect the main reason being that we all want 4+ GB of ram, and using that requires using a 64-bit Windows.
Severity: normal → enhancement
Depends on: 558781
OS: Windows 7 → Windows Server 2008
Priority: -- → P5
How much pressure are we currently feeling to make this change now that bug 582335 is fixed? 

jhford will be tackling the linux-equivalent of this soon (bug 633275).
Component: Release Engineering → Release Engineering: Platform Support
QA Contact: release → coop
Summary: Consider building 32 bit builds on 64 bit builders (at least for Windows) → Do 32-bit Windows builds on 64-bit Windows
Whiteboard: [win64]
It's less critical, but I have no doubt that we will creep our way back up in codesize to the point where we'll hit this again. This would buy us a whole extra gig of virtual memory, which is a lot of breathing room. Possibly enough to see us through to a world where we can either compile a 32-bit binary with a 64-bit compiler, or drop support for 32-bit builds.
For reference, here's our linker VM usage from a recent Win PGO build:
linker max virtual size: 2970206208 (bytes)

If that hits 3GB, we're toast.
It's tough to choose one of the two bugs, but I think (looking at a build that just died for lack of virtual memory, wondering whether or not a retrigger will also hit it) that edmorley came closer to the way we'll actually fix this, as a P1 blocker rather than a P5 enhancement.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 709480
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
(Assignee)

Updated

6 months ago
Component: Platform Support → Buildduty
Product: Release Engineering → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.