Closed Bug 584339 Opened 9 years ago Closed 9 years ago

In standalone window I cannot get rid of the scam warning

Categories

(Thunderbird :: Message Reader UI, defect)

x86
macOS
defect
Not set

Tracking

(blocking-thunderbird5.0 needed)

RESOLVED FIXED
Thunderbird 5.0b1
Tracking Status
blocking-thunderbird5.0 --- needed

People

(Reporter: Usul, Assigned: squib)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

1) save https://bugzilla.mozilla.org/attachment.cgi?id=462038
2) File -> Open Saved message

This opens in a standalone window on my system
I get a nice This my be  a scam warning. Clicking on ignore does nothing.
Whiteboard: [tb32needs] → [tbtrunkneeds]
Flags: blocking-thunderbird-next+
Whiteboard: [tbtrunkneeds]
Summary: In standalone window I can get rid of the scam warning → In standalone window I cannot get rid of the scam warning
blocking-thunderbird5.0: --- → needed
Flags: blocking-thunderbird-next+
For what it's worth, this works with other emails, just not that email.
Ah ha, I see what the problem is. .eml files don't work, but messages in a mail folder do work.
Taking this, since I think I have a solution (not necessarily a good one).
Assignee: nobody → squibblyflabbetydoo
Well, I'm not really sure this is the right way to go about doing this, but it seems to work, at least. This will, I'm sure, need tests, but I'm putting the patch up now so that people can try it with various test cases to make sure I actually got it right. :)
Attachment #526895 - Flags: feedback?(bugmail)
Comment on attachment 526895 [details] [diff] [review]
Allow reloading of external (file or attachment) messages

Yes, a test would be nice.  Since Standard8 is planning to have the standalone message display end up being a tabbed window like the rest, it might make sense to plan to internalize the external message display stuff more into the FolderDisplayWidget/MessageDisplayWidget world or the tab type.  But you don't need to do that now, this is fine.
Attachment #526895 - Flags: feedback?(bugmail) → feedback+
Attached patch Now with testsSplinter Review
Here are some tests. I'm a little surprised that this appears to be the first Mozmill test involving .eml files, but now that I added a helper function in test-folder-display-helpers, maybe people will write more tests for .eml files. :)
Attachment #526895 - Attachment is obsolete: true
Attachment #527683 - Flags: review?(bugmail)
Status: NEW → ASSIGNED
Comment on attachment 527683 [details] [diff] [review]
Now with tests

Vontastic.  Indeed, the lack of the .eml test was a bit of a deficiency; the whole refactoring and mozmill test writing was on the critical path for a release and it got short shrift.  Thanks much for resolving that!
Attachment #527683 - Flags: review?(bugmail) → review+
Checked in: http://hg.mozilla.org/comm-central/rev/2e67f19621cd
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a4
Blocks: TB2SM
Flags: in-testsuite+
No longer blocks: TB2SM
Depends on: 652942
I was looking into this but the one line fix in Thunderbird isn't sufficient. 

function setMsgHdrPropertyAndReload(aProperty, aValue)
{
  // we want to get the msg hdr for the currently selected message
  // change the appropiate property on it then reload the message

  var msgHdr = msgHdrForCurrentMessage();
  if (msgHdr)
  {
    msgHdr.setUint32Property(aProperty, aValue);
    ReloadMessage();
  }
}
We don't have a dummy Message Header sink like Thunderbird. so msgHdr is null here.
Bah wrong tab!
You need to log in before you can comment on or make changes to this bug.