In Bugzilla 3.6, searching for bugs with at least X votes is broken

VERIFIED FIXED in Bugzilla 3.6

Status

()

Bugzilla
Query/Bug List
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: karl155, Assigned: Max Kanat-Alexander)

Tracking

({regression})

3.6.1
Bugzilla 3.6
regression
Bug Flags:
approval3.6 +
blocking3.6.3 +

Details

(Whiteboard: [3.6 only; 4.x not affected], URL)

Attachments

(1 attachment)

v1
509 bytes, patch
Frédéric Buclin
: review+
Details | Diff | Splinter Review
(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: 

Now it is possible to enter every valid field in the serarch query. But that is the problem:
1. The serach mask says: "Only bugs with at least: ____ votes".
2. If you enter 50 you will get a query with "votes=50".
3. This ends with that result filter: "Votes: (is greater than) 49, Votes: 50"


Reproducible: Always
(Reporter)

Comment 1

7 years ago
Version: 3.6.1:

http://www.bugzilla.org/releases/3.6.1/release-notes.html
"Search: For those who like to make their own buglist.cgi URLs (and for people working on customizations), buglist.cgi now accepts nearly every valid field in Bugzilla as a direct URL parameter, like &field=value"
Version: unspecified → 3.6.1
(Assignee)

Comment 2

7 years ago
This is really blocking 3.6.3, but I'll change that when we have the flag.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking3.6.2+
Summary: With the latest Bugzilla it is no longer possible to search for bugs with at least x votes → In Bugzilla 3.6, searching for bugs with at least X votes is broken
Target Milestone: --- → Bugzilla 3.6

Comment 3

7 years ago
The SQL query has:

WHERE ((bugs.votes > '3') AND ( bugs.votes IN ('4') ))


Bugzilla 3.4 doesn't have this 2nd condition.

Comment 4

7 years ago
For the record, Bugzilla 4.0 and 4.1 are not affected. So this is a 3.6 only regression.
Keywords: regression

Updated

7 years ago
Flags: blocking3.6.2+ → blocking3.6.3+
Is there any workaround for this in 3.6? Any query that I could use to show all bugs of a given product with more than 50 votes?
https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&field0-0-0=votes&type0-0-0=greaterthan&value0-0-0=50&resolution=---&product=Thunderbird
(Assignee)

Comment 7

7 years ago
Created attachment 472589 [details] [diff] [review]
v1

Here's a patch to fix it in 3.6.
Assignee: query-and-buglist → mkanat
Status: NEW → ASSIGNED
Attachment #472589 - Flags: review?(LpSolit)

Comment 8

7 years ago
Comment on attachment 472589 [details] [diff] [review]
v1

Cool, thanks for the fix. :) r=LpSolit
Attachment #472589 - Flags: review?(LpSolit) → review+

Updated

7 years ago
Flags: approval3.6+
Whiteboard: [3.6 only; 4.x not affected]
(Assignee)

Comment 9

7 years ago
Hey, you're welcome! :-) Thanks for the review!

Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/3.6/                         
modified Bugzilla/Search.pm
Committed revision 7169.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Duplicate of this bug: 596890
Duplicate of this bug: 598005
(Reporter)

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.