Last Comment Bug 585841 - Right click, 'copy link location' no longer works
: Right click, 'copy link location' no longer works
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: mozilla2.0b4
Assigned To: Neil Deakin
:
: Neil Deakin
Mentors:
: 586275 586278 586429 (view as bug list)
Depends on:
Blocks: 383930 593575
  Show dependency treegraph
 
Reported: 2010-08-09 19:41 PDT by Jim Mathies [:jimm]
Modified: 2010-12-17 07:06 PST (History)
17 users (show)
sdwilsh: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
beta4+


Attachments
fix (3.62 KB, patch)
2010-08-10 08:23 PDT, Neil Deakin
no flags Details | Diff | Splinter Review
fix reference (3.62 KB, patch)
2010-08-10 11:21 PDT, Neil Deakin
neil: review+
Details | Diff | Splinter Review

Description Jim Mathies [:jimm] 2010-08-09 19:41:05 PDT
Error in the console:

Error: An error occurred executing the cmd_copyLink command: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIController.isCommandEnabled]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goDoCommand :: line 95"  data: no]
Source File: chrome://global/content/globalOverlay.js
Line: 100
Comment 1 Neil Deakin 2010-08-10 05:07:07 PDT
How odd, I must have unintentionally removed the nsDocumentViewer changes from the patches in bug 383930. A patch will be ready soon.
Comment 2 Neil Deakin 2010-08-10 08:23:42 PDT
Created attachment 464428 [details] [diff] [review]
fix

Check both popupNode locations
Comment 3 Neil Deakin 2010-08-10 11:21:01 PDT
Created attachment 464488 [details] [diff] [review]
fix reference

Bah, didn't seem to save the file before making the patch. This is the right patch.
Comment 4 neil@parkwaycc.co.uk 2010-08-10 11:49:41 PDT
Comment on attachment 464488 [details] [diff] [review]
fix reference

I was wondering about that, but the tree was red when I pulled, and by the time I had got my build working again, you had fixed the patch ;-)
Comment 5 Shawn Wilsher :sdwilsh 2010-08-10 14:00:23 PDT
Thank you for writing a test.

http://hg.mozilla.org/mozilla-central/rev/38d4fdfa9fd7
Comment 6 Neil Deakin 2010-08-11 07:23:23 PDT
*** Bug 586275 has been marked as a duplicate of this bug. ***
Comment 7 John P Baker 2010-08-11 07:34:46 PDT
*** Bug 586278 has been marked as a duplicate of this bug. ***
Comment 8 Benjamin Smedberg [:bsmedberg] 2010-08-11 14:05:22 PDT
*** Bug 586429 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.