Update system requirements page for Firefox 4

VERIFIED FIXED

Status

()

Firefox
General
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: marcia, Assigned: christian)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [hardblocker][noncode][ETA: 3/4])

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

7 years ago
Please see Bug 577290 for more information.
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?
blocking2.0: ? → betaN+
Platform requirements here: https://wiki.mozilla.org/Firefox/4/Platforms

I'll need some help coming up with:

 - Linux system requirements (minimum library support, etc)
 - Hardware requirements

for reference, these are our current specs:

http://www.mozilla.com/en-US/firefox/system-requirements.html
For Linux:

We could recommend Xorg server 1.7 or higher for optimal functionality (bilinear filters for image scaling) and performance.

We should still run with the same GTK+, GLib, Pango versions listed previously
as we build (and still run some basic tests I think) against those versions.

We don't run 32-bit plugins in 64-bit browsers, but 64-bit plugin in 64-bit browser architecture is the same as 32/32.
Depends on: 621704

Updated

7 years ago
OS: Mac OS X → All
Hardware: x86 → All
We require that the target Linux system come with libstdc++ for GCC 4.3 or newer.
Whiteboard: [softblocker]
We would like this to hardblock the release, because setting the right expectations will prevent a number of people from being really upset. It might not block Fx4 as piece of software, but this should be in place before we launch.
Whiteboard: [softblocker]
Whiteboard: [softblocker]

Comment 5

6 years ago
Created attachment 505623 [details]
Example of columned view in HMTL

It would be nice to show the three Operating Systems (Win, Mac, Lin) that are officially supported in columns, not listed, view - with a link to the page on downloading the source code underneath the three.

Comment 6

6 years ago
Is 32-bit builds only still correct?

Comment 7

6 years ago
Created attachment 506683 [details]
FF4 SysRequirements (absolute links)

This is a continuation of the previous example of SysRequirements in columns - except updated for FF4. NOTE: the links are all absolute and this should not just be copy-and-pasted onto the server. I will make a patch for the website later.

Comment 8

6 years ago
When working in the /projects/mozilla.com/trunk SVN tree, how do you manage the hundreds of language directories? Do I just work in en-US and ignore the others? Do I have to translate my additions for every language manually?
(In reply to comment #6)
> Is 32-bit builds only still correct?

We are shipping 64-bit releases of Firefox 4 on OS X and Linux. Note that the OS X builds are Universal 32/64-bit, so they should run on 10.6 or 10.5 on either x86 or x86-64 CPUs.

Comment 10

6 years ago
I would generally like this bug fixed before the 4.0 release...

The Beta 11 Release notes are still linking to the 3.6 system requirements.. which I am pretty sure will not work with 4.0.

On another note, this will be somewhat important in future troubleshooting.. as people will be wondering why Firefox will not run on their PPC Tiger machine.. or why Firefox runs slow on their machine with 64MB of RAM... I know it is rare that people will have such a small amount anymore... but I'm betting there are still a few out there.

I would like a clear way to know if your video card supports hardware acceleration too.. but thats another matter.

Comment 11

6 years ago
Well Attachment #506683 [details] is an edit of the current 3.6 page. the important bit is the bit in <div id="main-content" />.

That's a table of the requirements as documented here and in Bug #577290.

If someone who can be bothered with CVS (why aren't we on git or Bazaar?!?) then they should basically copy that <div /> to the version-controlled page.
blocking2.0: betaN+ → final+
Whiteboard: [softblocker] → [hardblocker]

Comment 12

6 years ago
For a bit of perspective.. the minimum system requirements to install OSX 10.5 is here: http://support.apple.com/kb/HT3759

Summary: 867MHz or faster.. and 512MB of RAM

Also.. For Windows Vista.. http://windows.microsoft.com/en-us/windows-vista/products/system-requirements

Summary: 800MHz or faster.. and 1GB of RAM

I know the needs of 2000 and XP may be less than Vista and Win 7.... though I don't know if there should be different requirements for different Windows versions... as that may get confusing.

Comment 13

6 years ago
All the requirements are there for is to say what we expect to work. Firefox comes with absolutely no warranty. So it's ok for them to be semi-simplified.

Comment 14

6 years ago
As bsmedberg said earlier, there is a minimum requirement on the Linux platform for libstdc++ 4.3.0 or greater when running Firefox 4. Whilst all the other Linux requirements in attachment 506683 [details] are exactly satisfied in CentOS 5.5 (implying that was the system used for establishing them), the libstdc++ requirement is not, as detailed in bug 621704 (the workaround for CentOS 5.5 is to extract a later libstdc++ library - e.g. from Fedora 9 - and put it in the Firefox install tree). Hence, I would suggest that the libstdc++ requirement is added to the Linux list - I have been running Firefox 4.0b9 and later betas with the aforementioned workaround fine on CentOS 5.5.

Comment 15

6 years ago
It's hard to believe Firefox 4 will work with 64 or even 256 MB of RAM except on trailing edge static HTML sites, and even with such sites has someone tried opening five tabs and Tab Candy?  I think the requirements page should have a blanket statement along the lines of "Many modern web pages require hundreds of megabytes of RAM for fast performance" because web browsing is now the most resource-intensive activity that most computer users perform.

(FWIW, something on planet.mozilla.org yesterday repeatedly consumed all my RAM unless I disabled JavaScript, it seems even 1GB isn't enough any more.)
It would be interesting for me if i can assume SSE2. Currently we need different checks in the JavaScript Engine, to check if different levels of SSE support are available. If we could assume SSE2 support after Firefox 4, Bug 530896, would be a lot easier to finish.

Comment 17

6 years ago
(In reply to comment #16)
> It would be interesting for me if i can assume SSE2.

I know 2 people who still run Pentium3 machines, one has a dual P3/866MHz machine and the other has a single 1.2GHz CPU.  Both on WinXP.  My observation is that Firefox 3.6.x runs pretty well on both machines.

Changing the minimum requirements to a SSE2-capable processor will have a lot of people baying for your blood.
We made the decision several months ago not to require SSE2 for Firefox 4.

Comment 19

6 years ago
We have no automated test coverage for non-SSE2 machines.

Comment 20

6 years ago
Created attachment 515416 [details]
FF4 SysRequirements (absolute links)

Updated the requirements to reflect recent comments.

Also tweaked some minor HTML

A patch still needs to be formulated by someone.
Attachment #505623 - Attachment is obsolete: true
Attachment #506683 - Attachment is obsolete: true

Comment 21

6 years ago
Created attachment 515418 [details]
<div id="main-content" /> to <!-- end div#main-content -->

This contains only the main-content div (<div id="main-content" /> or div#main-content).

Note, the XML comment <!-- end #content div --> signifying the end of the <div /> has been replaced with <!-- end div#main-content --> for clarity.


To create a patch from this, simply replace everything from (and including)  <div id="main-content">  to/and  </div><!-- end #content div -->  with the attached text.
Created attachment 515487 [details] [diff] [review]
Patch with conforming markup

Someone'd need to write some CSS, I suppose.

Comment 23

6 years ago
What's missing from the CSS, it looked fine on the "mockup" HTML?

Comment 24

6 years ago
(In reply to comment #19)
> We have no automated test coverage for non-SSE2 machines.

http://tinderbox.mozilla.org/showbuilds.cgi?tree=GeriatricMachines

Comment 25

6 years ago
From my understanding... the system requirements are based off of what the minimum hardware is needed to run the minimum supported operating system.

... If we keep the rule that it just needs the minimum needed for the OS... then I have some things to note that should be changed:

1. For Windows 2000, the minimum needed RAM is 32MB of RAM, (64 Recommended)and 133MHz processor.
2. For OSX 10.5. The minimum needed RAM is 512MB of RAM (Or More) And an Intel Processor (As Power PC's are no longer supported)
____
When it comes to computer games, a lot of times people look to the required and recommended hardware, to know what they need, in order for the game to be "usable"... I don't know if 32MB or even up to 512MB on a 2000 machine would be "usable"

Comment 26

6 years ago
32MB is not realistic. 128MB maybe.

Comment 27

6 years ago
comment #24: 4 columns are perma-red, 3 perma-orange. My point exactly.

Comment 28

6 years ago
Bug 579078 was where the decision was made on Windows 2000 support. I asked if tests were being run on it, but didn't get a reply (see bug 579078 comment 23).

Comment 29

6 years ago
(In reply to comment #23)
> What's missing from the CSS, it looked fine on the "mockup" HTML?

The "conforming" attachment does not match the earlier mockup at all. It has vertically centered table cells, the table headers are not sized, etc. In other words, <tr valign=top> became <tr>, <td...><h2>...</h2></td> became <th>, etc.

In addition, both the mockup and the patch have no horizontal padding between columns.

The columns are an improvement on the Firefox 3.6 requirements page.
http://www.mozilla.com/en-US/firefox/system-requirements.html

Comment 30

6 years ago
The patch copy & paste the contents of Attachment #515418 [details] into the new page and update the title/etc. It should not edit Attachment #515418 [details] at all when pasting.

The patch should also move the 3.6 page into firefox/3.6/system-requirements.html

Also does anyone know why when set to width 100%, it is only the width of the header "System Requirements"?

> In addition, both the mockup and the patch have no horizontal padding between
> columns.
Is padding really necessary in this case?

Comment 31

6 years ago
Attachment #515418 [details] has things like
'<table width=100% boarder=0>'
which is a typo.

The "conforming" attachment removed the HTML attributes of <table>, <tr>, <td>. So it needs 'valign="top"' or equivalent CSS.

The Attachment #515416 [details] mockup shows why horizontal padding between the three columns is needed.
Whiteboard: [hardblocker] → [hardblocker][noncode]
Whiteboard: [hardblocker][noncode] → [hardblocker][noncode][ETA: 3/4]

Comment 32

6 years ago
... To further my quest... to have some realistic RAM requirements... I would like to also point to the Mozilla Thunderbird System Requirements... which seems to be way more power intensive... then FF4...

http://www.mozillamessaging.com/en-US/thunderbird/system-requirements/

On Thunderbird... the ram is listed out per OS... and actually has somewhat near sane numbers.

Comment 33

6 years ago
Right now, you're talking about hardware requirements only.
What about software ?

Specifically, that 'HAL 0.5.8 or higher' part.

As probably everyone knows by now, hal has been put in fixes-only mode awhile back and while its replacement (udisks/upower combo) has it's own shortcomings (my personal pet peeve is http://bugs.freedesktop.org/show_bug.cgi?id=25613), major desktop environments have moved to it either awhile ago or lately.

AFAICT, firefox isn't even using it directly, just via gnome-vfs (which has been deprecated for even longer and 2.0 of xulrunner has a gio module to replace it anyway).
(so OK, parts of what they do with Gnome 3.0 are more than a bit crazy, but that's a different topic)

Perhaps a minor clarification should be added there ?

Comment 34

6 years ago
What about Windows Server 2008?

Comment 35

6 years ago
is this still not landing till the 4th when RC is planned to be complete before than?

Comment 36

6 years ago
Any strong reason why this is filed as a Firefox bug vs a mozilla.com one? If not, I'll move it over to that component so it can batched with the rest of the site release.

Comment 37

6 years ago
(In reply to comment #36)
> Any strong reason why this is filed as a Firefox bug vs a mozilla.com one? If
> not, I'll move it over to that component so it can batched with the rest of the
> site release.

I was wondering this myself because this really has nothing to do with firefox 4 itself more to do with the website not being fully up to date.

Comment 38

6 years ago
(In reply to comment #36)
> Any strong reason why this is filed as a Firefox bug vs a mozilla.com one? If
> not, I'll move it over to that component so it can batched with the rest of the
> site release.

It's a site issue, so it should be moved there.
(Assignee)

Updated

6 years ago
Duplicate of this bug: 577290
(In reply to comment #36)
> Any strong reason why this is filed as a Firefox bug vs a mozilla.com one? If
> not, I'll move it over to that component so it can batched with the rest of the
> site release.

Likely because the Mozilla.com component doesn't have the same blocking-Firefox flags...
Slater, this bug is actually more about me collating and gathering the system requirements so we know what they are before we ship. Anyway, I'll have it done in an hour or so.

Comment 42

6 years ago
This is now the last blocker for FF4, according to http://canweshipyet.com/

Comment 43

6 years ago
there are now two blockers so this isnt the last one anymore..

Comment 44

6 years ago
Can we unblock RC on this?
This doesn't block RC, it blocks ship.

Comment 46

6 years ago
Sorry to ask this here, but since the can-we-ship-yet list was mentioned...

Will RC/final ship for all languages and all systems (win64 is not available in quite a few languages for example), or will we ship with en-US for all systems initially and then start building for other systems/languages?
It will ship for all supported systems, and all locales.  Win64 is not a supported build in FF4.

Comment 48

6 years ago
what will happen with FF4 x64 nightly build after ship, no more new x64 nightly?
File updated in r83983 on trunk; I'll go through and update all the links for release note pages before pushing live.

The plan is:

 - retarget all 3.6.* links to system-requirements-v3.6.html
 - target 4.0 release notes to system-requirements-v4.html

this will make system-requirements.html obsolete. Yay.
(Assignee)

Comment 50

6 years ago
Can't we put it in en-US/firefox/4.0/system-requirements.html and en-US/firefox/3.6/system-requirements.html? Seems like that would be a bit cleaner (or even /system-requirements/index.html like details, whatsnew, and release notes)
Man, you should have seen this coming ;)
Assignee: beltzner → clegnitto

Comment 52

6 years ago
Is Firefox is compatible with 64-bit Windows?
Firefox will run just fine on 64-bit Windows as a 32 bit process.

Comment 54

6 years ago
(In reply to comment #53)
> Firefox will run just fine on 64-bit Windows as a 32 bit process.

Does that apply to Windows XP x64 because Windows XP's WOW64 isn't too powerful.

Comment 55

6 years ago
Is Firefox 4 compatible with Windows Server 2008?

Comment 56

6 years ago
OK, I think there is enough info in this bug now to fit the purpose outlined I'm Comment #

> This doesn't block RC,
> it blocks ship.
The RC is meant to be the same as final. Blocking final blocks the RC.
This bug should not be blocking20:final.

Comment 57

6 years ago
(In reply to comment #56)
This is not a Firefox bug; it's a Mozilla.com bug. It doesn't add anything to Firefox itself so it doesn't affect the RC or final software release, just the web material to go with it. The only reason it's in Firefox:General with a blocking flag is to keep track of it because the website components can't block. I guess the proper thing to do would to be to add a flag for website components to block final shipping, but it doesn't come up all too often and those who are working on this and the RC know what's what. ;)

Comment 58

6 years ago
> those who are working on this and the RC know what's what. ;)

Well they obviously do, since build1 of Firefox 4.0 RC1 is now on the server[1][2].

[1] ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/4.0rc1-candidates/
[2] https://wiki.mozilla.org/Releases/Firefox_4.0rc1
(Assignee)

Comment 59

6 years ago
And it's done on trunk. Need to push to staging, QA, and then live:

http://viewvc.svn.mozilla.org/vc?view=revision&revision=84145
through
http://viewvc.svn.mozilla.org/vc?view=revision&revision=84151
(Assignee)

Comment 60

6 years ago
If any webdever wants to take this over for the stage+QA+production part, by all means take this from me. I don't have time this weekend to commit to getting this live so it will take until Monday if you wait for me (unless I have a wicked hangover on Sunday and push it from bed).
(Assignee)

Comment 61

6 years ago
Also rev 84287 for an issue with poor interaction between blanket 4.0 redirects
qa-verified-trunk https://www-trunk.stage.mozilla.com/en-US/firefox/4.0/system-requirements/index.html

Comment 63

6 years ago
There is still no status for Windows Server 2008.

Comment 64

6 years ago
The Linux section doesn't have hardware requirements. Is SSE2 required there too, for example?
(Assignee)

Comment 65

6 years ago
Pushed live in http://viewvc.svn.mozilla.org/vc?view=revision&revision=84297. I think we can handle specific questions like comment 55 and 64 in a follow up.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
verified fixed http://www.mozilla.com/en-US/firefox/4.0/system-requirements/index.html
Status: RESOLVED → VERIFIED

Comment 67

6 years ago
For some reason, the Linux libstdc++ requirement (needs 4.3.0 or later) seems to have dropped off the "fixed" Firefox 4 requirements page. Any reason why this would be? Without it, CentOS 5.5 satisfies the current "fixed" requirements and yet it can't run Firefox 4 out of the box.

Comment 68

6 years ago
Reopening to at least get a response to comment 67. The libstdc++ requirement was in the agreed list of system requirements (as attached) but seems to have been dropped unintentionally when making the patch.  But as this is live already, maybe that now has to be a follow up bug?
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 69

6 years ago
I don't know if this is to be mentioned here or not, the link at http://www.mozilla.com/en-US/firefox/4.0/system-requirements/index.html for firefox 4 download is pointing to http://www.mozilla.com/products/download.html?product=firefox-3.6.15&os=osx&lang=en-US
I guess it's normal since it's not released yet...
(Assignee)

Comment 71

6 years ago
Pushed live the libstdc++ requirement in 84699. Please file a followup for further clarifications (and set this bug as blocking).
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED

Comment 72

6 years ago
(In reply to comment #69)
> I don't know if this is to be mentioned here or not, the link at
> http://www.mozilla.com/en-US/firefox/4.0/system-requirements/index.html for
> firefox 4 download is pointing to
> http://www.mozilla.com/products/download.html?product=firefox-3.6.15&os=osx&lang=en-US

Seems bad.
Firefox home page http://www.mozilla.com/en-US/firefox/
Links to: http://www.mozilla.com/en-US/firefox/RC/
Links to: http://www.mozilla.com/en-US/firefox/all-beta.html
Links to: http://www.mozilla.com/en-US/firefox/4.0rc1/releasenotes/
Links to: http://www.mozilla.com/en-US/firefox/system-requirements.html
Big icon for "Firefox 4.0 Free Download" in upper right.
Link goes to: Firefox 3.6.15

User scenario: Home page > What's this, Firefox 4 RC, wonder if it works on my system? >>>> OK, it does, let's download it > Click "Firefox 4.0" > Get Firefox 3.6.15.

Comment 73

6 years ago
It's now bug Bug 640461.
Simpler scenario: Slashdot article > Release Notes > System Requirements > 3.6.15
(Assignee)

Comment 74

6 years ago
Ah! Looks like the wrong revision might have got pushed live for the release notes, as trunk has the proper link.
(Assignee)

Comment 75

6 years ago
Note comment 74 doesn't fix bug 640461, merely explains why http://www.mozilla.com/en-US/firefox/system-requirements.html showed up in the STR in comment 72

Comment 76

6 years ago
In reply to comment 65 and comment 71
> I think we can handle specific questions like comment 55 and 64 in a follow up.
I filed bug 640783.

Comment 77

6 years ago
(In reply to comment #71)
> Pushed live the libstdc++ requirement in 84699.

Returning to verified fixed, with that.
Status: RESOLVED → VERIFIED
As some people said, where's Windows Server 2008? (IE9 supports the system)

Comment 79

6 years ago
> As some people said, where's Windows Server 2008? (IE9 supports the system)
See bug 640783.

Comment 80

6 years ago
OK, the scenario in Comment 72 is now fixed. Release notes links to http://www.mozilla.com/en-US/firefox/4.0rc1/system-requirements/
which has the 4.0RC download link and image.

Also, http://www.mozilla.com/en-US/firefox/system-requirements.html now has the  4.0RC download link and image.
You need to log in before you can comment on or make changes to this bug.