Unable to close Tab groups

RESOLVED FIXED in Firefox 4.0b4

Status

Firefox Graveyard
Panorama
P1
normal
RESOLVED FIXED
8 years ago
2 years ago

People

(Reporter: Matheus Kerschbaum, Assigned: mitcho)

Tracking

Trunk
Firefox 4.0b4
All
Windows 7
Dependency tree / graph
Bug Flags:
in-litmus +

Details

(Whiteboard: fixed by 586685 [Aug-13-testday], [in-litmus-bug-week])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b4pre) Gecko/20100812 Minefield/4.0b4pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b4pre) Gecko/20100812 Minefield/4.0b4pre

In latest m-c build, with tabcandy enabled, I'm unable to close tab groups. It looks like the close button is beneath the Title of groups, so clicking it activates the editor rather than closing the group.

Reproducible: Always

Steps to Reproduce:
1.Create a tab group
2.Attempt to close it
Actual Results:  
Unable to close it.

Expected Results:  
Should be able to close it.

Built from http://hg.mozilla.org/mozilla-central/rev/5da28c582cc7
(Reporter)

Updated

8 years ago
Blocks: 586788
blocking2.0: --- → ?
Version: unspecified → Trunk
I can confirm this too.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

8 years ago
Whiteboard: b4
I can confirm this on the latest hourly trunk build on Windows 7. (http://hg.mozilla.org/mozilla-central/rev/c8ee0c411f5e)
This will be fixed with the proposed patch for bug 586685.

Updated

8 years ago
Priority: -- → P1
Whiteboard: b4 → [Aug-13-testday][b4]
(In reply to comment #3)
> This will be fixed with the proposed patch for bug 586685.

Are your sure? You didn't actually mention the wrong bug number? The summary seems to be about something completely different.
(In reply to comment #4)
> (In reply to comment #3)
> > This will be fixed with the proposed patch for bug 586685.
> 
> Are your sure? You didn't actually mention the wrong bug number? The summary
> seems to be about something completely different.

Yes, unfortunately the fix for this bug got wrapped up in the patch for that one.

Comment 6

8 years ago
I can confirm this on Mozilla/5.0 (Windows NT 6.1; rv:2.0b4pre) Gecko/20100813 Minefield/4.0b4pre

Updated

8 years ago
Depends on: 586685

Updated

8 years ago
No longer depends on: 586685
Component: Tabbed Browser → TabCandy
QA Contact: tabbed.browser → tabcandy

Updated

8 years ago
Depends on: 586685

Updated

8 years ago
Duplicate of this bug: 587137

Comment 8

8 years ago
Fixed by 586685
http://hg.mozilla.org/mozilla-central/rev/62e087ddf724
Assignee: nobody → mitcho
Whiteboard: [Aug-13-testday][b4] → fixed by 586685 [Aug-13-testday]
Target Milestone: --- → Firefox 4.0b4

Comment 10

8 years ago
http://hg.mozilla.org/mozilla-central/rev/802b081c9658
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Duplicate of this bug: 581730
Post-fix blocking+.
blocking2.0: ? → betaN+

Updated

7 years ago
Flags: in-litmus?
In litmus +'d. Test case 12654.
Flags: in-litmus? → in-litmus+
Whiteboard: fixed by 586685 [Aug-13-testday] → fixed by 586685 [Aug-13-testday], [in-litmus-bug-week]
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.