Last Comment Bug 586822 - [Non-static SeaMonkey] "Warning: package error or possible missing or unnecessary file: bin/libgfxpsshar.so (package-manifest, 54)."
: [Non-static SeaMonkey] "Warning: package error or possible missing or unneces...
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Build Config (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: seamonkey2.1b1
Assigned To: Serge Gautherie (:sgautherie)
:
Mentors:
http://mxr.mozilla.org/comm-central/s...
Depends on: 571989 585462
Blocks: 564606 713134
  Show dependency treegraph
 
Reported: 2010-08-12 16:47 PDT by Serge Gautherie (:sgautherie)
Modified: 2011-12-30 04:49 PST (History)
3 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
(Av1) Stop packaging @DLL_PREFIX@gfxpsshar@DLL_SUFFIX@. [Checkin: Comment 3] (2.05 KB, patch)
2010-08-12 16:59 PDT, Serge Gautherie (:sgautherie)
kairo: review+
Details | Diff | Splinter Review

Description Serge Gautherie (:sgautherie) 2010-08-12 16:47:13 PDT
No warning:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1277759157.1277764821.30274.gz&fulltext=1
Linux comm-central-trunk leak test build on 2010/06/28 14:05:57

Warning:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1277803320.1277810614.3126.gz&fulltext=1
Linux comm-central-trunk leak test build on 2010/06/29 02:22:00
...
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1281640374.1281646039.12442.gz&fulltext=1
Linux comm-central-trunk leak test build on 2010/08/12 12:12:54
{
Warning: package error or possible missing or unnecessary file: bin/libgfxpsshar.so (package-manifest, 54).
}

My initial attempt for a regression timeframe found
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=00bf38db60e2&tochange=a9501fcd9c25
which is confusing me as nothing seems related :-/
(It looks like the timeframe is "just" _after_ the expected changeset, no?)

Anyway, the cause is bug 571989 comment 17
http://hg.mozilla.org/mozilla-central/rev/72b5eccbe07c

PS: See discussion in bug 585462 too...
Comment 1 Serge Gautherie (:sgautherie) 2010-08-12 16:59:49 PDT
Created attachment 465467 [details] [diff] [review]
(Av1) Stop packaging @DLL_PREFIX@gfxpsshar@DLL_SUFFIX@.
[Checkin: Comment 3]

Ftr, I'm (only) moving the lines in removed-files.in, to be safe,
though I wonder whether they could just be removed: see discussion in bug 585462).
Comment 2 Robert Kaiser 2010-08-17 11:46:22 PDT
Comment on attachment 465467 [details] [diff] [review]
(Av1) Stop packaging @DLL_PREFIX@gfxpsshar@DLL_SUFFIX@.
[Checkin: Comment 3]

gah, we're getting way too many ifdefs in removed-files.in, I'll be so happy once we can trash most of this infuriating mess.
Comment 3 Serge Gautherie (:sgautherie) 2010-08-17 12:37:38 PDT
Comment on attachment 465467 [details] [diff] [review]
(Av1) Stop packaging @DLL_PREFIX@gfxpsshar@DLL_SUFFIX@.
[Checkin: Comment 3]

http://hg.mozilla.org/comm-central/rev/93c25054d748

Note You need to log in before you can comment on or make changes to this bug.