Last Comment Bug 587021 - drop HTMLImageElement.x/.y
: drop HTMLImageElement.x/.y
Status: VERIFIED WONTFIX
: dev-doc-complete
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla7
Assigned To: :Ms2ger
:
Mentors:
Depends on: 731832
Blocks: 98292 660439
  Show dependency treegraph
 
Reported: 2010-08-13 08:01 PDT by Anne (:annevk)
Modified: 2014-08-04 01:05 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (3.38 KB, patch)
2010-08-14 09:10 PDT, :Ms2ger
jonas: review+
jst: superreview+
benjamin: approval2.0-
Details | Diff | Review

Description Anne (:annevk) 2010-08-13 08:01:57 PDT
Internet Explorer does not implement these and it would be nice to get rid of them everywhere I think.
Comment 1 :Ms2ger 2010-08-14 09:10:28 PDT
Created attachment 466006 [details] [diff] [review]
Patch v1

Unsurprisingly, we don't appear to have tests for this.
Comment 2 Jonas Sicking (:sicking) 2010-08-15 16:42:51 PDT
Comment on attachment 466006 [details] [diff] [review]
Patch v1

We might actually want to keep binary compatibility here, unfortunately.

So simply prefix the attributes in the idl with [noscript] and add a comment stating that these are DEPRECATED. Then keep implementations, but make them simply return NS_ERROR_NOT_IMPLEMENTED or some such.

I know this interface isn't marked FROZEN, and that FROZEN doesn't even mean very much any more, but I strongly suspect there are addons that use this interface.

r=me with that changed.
Comment 3 :Ms2ger 2010-08-16 04:23:59 PDT
Comment on attachment 466006 [details] [diff] [review]
Patch v1

We already broke them in bug 582303, so I don't see how preserving binary compat here would be useful.
Comment 4 Jonas Sicking (:sicking) 2010-08-16 09:24:36 PDT
Ok, let's stick with this patch then.
Comment 5 Benjamin Smedberg [:bsmedberg] 2010-08-18 08:53:02 PDT
Comment on attachment 466006 [details] [diff] [review]
Patch v1

This is pure risk now, please wait until after branching.
Comment 6 :Ehsan Akhgari (busy, don't ask for review please) 2011-04-12 18:05:36 PDT
This doesn't apply cleanly any more.
Comment 8 Ioana (away) 2011-09-13 01:56:56 PDT
Clean-up visible in the 
content/html/content/src/nsHTMLImageElement.cpp
dom/interfaces/html/nsIDOMHTMLImageElement.idl
files.
Comment 9 Boris Zbarsky [:bz] 2012-03-16 14:22:25 PDT
This caused bug 731832.
Comment 10 :Ms2ger 2012-04-25 00:27:03 PDT
Backed out: https://hg.mozilla.org/mozilla-central/rev/75c7378c87b6
Comment 11 Florian Bender 2014-08-03 15:21:28 PDT
Was it intended to WONTFIX on backout? Seems pretty unusual to me ;)
Comment 12 :Ms2ger 2014-08-04 01:05:11 PDT
Yes.

Note You need to log in before you can comment on or make changes to this bug.