TabCandy lets you switch to tabs that are not open in the current group

RESOLVED DUPLICATE of bug 592179

Status

RESOLVED DUPLICATE of bug 592179
8 years ago
3 years ago

People

(Reporter: sciguyryan, Assigned: aza)

Tracking

Trunk
x86
Windows 7

Details

(Reporter)

Description

8 years ago
TabCandy currently lets you switch to a tab that isn't in the current tab group - this could potentially be confusing to an end user who could wonder where all the other tabs have gone.

I have two suggestions for this:

1. Make the switch to tab option show "switch to tab group" when the tab is in another group.
2. Make the switch to tab option import the tab into the current group instead.

As it currently stands it could cause confusion, I was wondering where my tabs went and so it is likely others would also.

Comments anyone?
I think Suggestion 1 will make more sense. Switching to another tab in another group should not change which group the tab is in. If tabs change groups, users may find it irradiating that he have to regroup his tabs again after he switch to those tabs that is in another group.
Assignee: nobody → aza
(Assignee)

Comment 2

8 years ago
@Ryan: I'm looking for clarification. In what way do you mean the user can switch to a tab that isn't in the current group?
There's the switch-to-tab feature in the location bar.
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> There's the switch-to-tab feature in the location bar.

That's the one yes.

Comment 5

8 years ago
I was just about to file a bug to request making it possible to "switch to a named tab group."

Switch-to-tab-in-other-group, along with Alt-1-9, is my main way of using tabcandy. So I basically use it as a context manager, with the main (awesome) draggy-UI just being the thing that I use to actually put things where they are, and occasionally for recall.

To support my personal use case (which, I know, important) I think it would be great if the switch-to-tab feature integrated with tab groups like this:

  * say you've got two groups, one unnamed and one named "work" with pages "fuzzy cats" and "angry dogs" in the first and a page "important" in group "work", and you are looking at "fuzzy cats", when you type in the awesomebar:

    ** "angry dogs": the text reads "switch to tab: angry dogs"

    ** "important": the text reads "switch to tab in group 'work': important"

    ** "work": the text reads "switch to tab group: work"

    and if you were looking at "important" (and therefore in group "work") and you started trying to switch to "fuzzy cats" the text would read "switch to tab in other group: fuzzy cats".

Obviously that would all be much more readable with decent styling, hopefully making it unnecessary for people to consciously read the "switch to..." part. (I know I don't.)
(Assignee)

Comment 6

8 years ago
In the way of disclosure, it makes a lot of sense to indicate if a tab matched in the awesome bar comes from another group.

* If the group is named, it should say "switch to tab in group [name]".
* If the group is unnamed, it should say "switch to tab in other group".

It should also be possible to switch to a group by name as Brandon mentioned.

* "switch to group", which will return you to the last tab in that group which you were viewing
(Assignee)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 592179
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.