Closed Bug 592179 Opened 13 years ago Closed 11 years ago

Enable switch to group in awesome bar

Categories

(Firefox :: Address Bar, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX
Future

People

(Reporter: aza, Unassigned)

References

Details

In the way of disclosure, it makes a lot of sense to indicate if a tab matched
in the awesome bar comes from another group.

* If the group is named, it should say "switch to tab in group [name]".
* If the group is unnamed, it should say "switch to tab in other group".

It should also be possible to switch to a group by name as Brandon mentioned.

* "switch to group", which will return you to the last tab in that group which
you were viewing
Assignee: nobody → raymond
Priority: -- → P4
Is this a duplicate of bug 594995?
Priority: P4 → --
(In reply to comment #2)
> Is this a duplicate of bug 594995?

The aspect of this bug that is not a duplicate is the ability to switch to a group by typing its name into the awesome bar. Edited title to reflect this. 

We've passed feature freeze; punting this to post-ff4.
Summary: Enable switch to group in awesome bar and name tabs being switched to → Enable switch to group in awesome bar
Target Milestone: --- → Future
Moving this to Location Bar component as bug 644215 is a dupe of it
Assignee: raymond → nobody
Component: Panorama → Location Bar
QA Contact: panorama → location.bar
Blocks: 626527
I've now been using FF4 with Panorama for a bit now and I'd add this as well:

1. User clicks CTRL-ALT-TAB
2. Firefox pops up a window showing the different tab groups as small icons
3. Clicking CTRL-ALT-TAB moves to the next group (highlights it in that window, or if they type and release quickly, just changes to that)

The problem with Panorama right now is a MAJOR lack of efficiency. I find I have to switch groups quite frequently and it's making Panorama a burden. With a quick keyboard shortcut to switch groups, Panorama suddenly becomes MORE efficient, not less.
(In reply to comment #6)
> The problem with Panorama right now is a MAJOR lack of efficiency. I find I
> have to switch groups quite frequently and it's making Panorama a burden. With
> a quick keyboard shortcut to switch groups, Panorama suddenly becomes MORE
> efficient, not less.

Note that ctrl+` will move you to the next group and ctrl+shift+` will take you to previous group.
(In reply to comment #7)
> (In reply to comment #6)
> > The problem with Panorama right now is a MAJOR lack of efficiency. I find I
> > have to switch groups quite frequently and it's making Panorama a burden. With
> > a quick keyboard shortcut to switch groups, Panorama suddenly becomes MORE
> > efficient, not less.
> 
> Note that ctrl+` will move you to the next group and ctrl+shift+` will take you
> to previous group.

OK, but that is completely non-intuitive. No one ever uses that key with control for anything first of all, but secondly it's missing the popup window to show you what group you're tabbing to. If I have 6 groups, doing ctrl+` is going to be annoying and very inefficient. Especially since I won't know what order they're in.

The popup showing small icons with names or something is needed.
 probably makes sense to Mac people, they use Alt+` to toggle between windows of the same program. And Ctrl+Alt+Tab is taken by most Linux Window managers as "Switch between windows on all desktops."

Keybindings are hard.

One thing that I would like though would be if the Panorama screen would show a list of keybindings when a key (eg "?") is pressed, like gmail does if you have settings configured correctly. I had no idea about this particular shortcut until it came up in the bug.

And, if someone decides to put in the effort to add something more like a static group switcher (which I think would be nice) to Panorama I would like to point out that I think we could take more advantage of spacial memory by having it operate like:

(1) Ctrl+` switches to Panorama, and selects the next group with noticable highlighting.
(2)  Pressing Ctrl+` repeatedly moves selection to the next group (and highlights it).
(3) Releasing Ctrl makes the currently selected group the current tab group, and exits the Panorama view.
wontfix per bug 836758
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.