Last Comment Bug 587771 - Seamonkey 2.1.x PPC nightly build fails to launch
: Seamonkey 2.1.x PPC nightly build fails to launch
Status: RESOLVED WORKSFORME
:
Product: SeaMonkey
Classification: Client Software
Component: General (show other bugs)
: unspecified
: PowerPC Mac OS X
: -- critical with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 587612 587799
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-16 13:05 PDT by Adam Jimerson
Modified: 2010-09-28 05:57 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Adam Jimerson 2010-08-16 13:05:56 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.3a6pre) Gecko/20100629 SeaMonkey/2.1a2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.3a6pre) Gecko/20100629 SeaMonkey/2.1a2

Seamonkey 2.1 Nightly build from both http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/2.1a3-candidates/ and http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/2010-08-16-05-comm-central-trunk/ installs without problems (no error messages are displayed during the installation) but Seamonkey fails to install, I had to install the Alpha 2 build to get a working copy.

Reproducible: Always

Steps to Reproduce:
1. Install the 20100816 build of SeaMonkey on a PPC Mac OSX 10.5
2. Try to launch SeaMonkey

Actual Results:  
The icon for SeaMonkey shows up on the doc and looks like it is launching but after about a minute or so the icon disappears and nothing else happens

Expected Results:  
SeaMonkey starting?

I'm unsure of how to start SeaMonkey from the command line, both seamonkey and seamonkey-bin returns "command not found".  I tests the builds between Alpha 2 (20100629) and the 20100816 build and test which is the last working build.
Comment 1 Matthias Versen [:Matti] 2010-08-16 14:53:07 PDT
could be related to bug 587799
Comment 2 Adam Jimerson 2010-08-16 22:08:27 PDT
Ok so I managed to get the following from launching it from iTerm:

Odin:~ vendion$ /Applications/SeaMonkey.app/Contents/MacOS/seamonkey-bin
2010-08-17 01:03:16.099 seamonkey-bin[1730:10b] *** _NSAutoreleaseNoPool(): Object 0xb51f950 of class NSCFDictionary autoreleased with no pool in place - just leaking
Stack: (0x91927dac 0x91854e14 0x25bc60 0x26e10c 0x26e5a4 0x26eab0 0x2811b5c 0xa8bc84 0xa928b0 0x25f7330 0x25f9f7c 0x25effe0 0x25f7344 0x25f9f7c 0x25fa620 0x25fa7f0 0x26104d0 0x25ee9f4 0x25f7344 0x25f9f7c 0x25fa620 0x25fa7f0 0x26104d0 0x25ee9f4 0x25f7344 0x25f9f7c 0x25fa620 0x2591168 0xa86f50 0x2811a68 0x281239c 0xc09c14 0x2811b5c 0xa8bc84 0xa928b0 0x25f7330 0x25f9f7c 0x25effe0 0x25f7344 0x25f9f7c 0x25fa620 0x2591168 0xa86f50 0x28119d4 0x281239c 0x27c53d0 0x27c5910 0x9000 0x2ee0 0x2d64)

I don't know if this is of any help as to what is going on, I'm not sure it this is related to bug 587799 because SeaMonkey crashes before a window even appears.
Comment 3 simon anderson 2010-08-17 00:09:01 PDT
I think this might be Bug 586848
Comment 4 Karsten Düsterloh 2010-08-23 03:55:28 PDT
Yes, related to bug 587799 or more precisely the YARR landing, which doesn't seem to work well with PPC builds (like mine)...

You probably can start from Terminal with -mail, but opening the browser will fail.
Comment 5 Matthias Versen [:Matti] 2010-09-15 11:08:23 PDT
Note: Firefox4 dropped PPC support https://wiki.mozilla.org/Firefox/4/Platforms
Comment 6 Adam Jimerson 2010-09-15 18:16:38 PDT
So I  take it that means Seamonkey will drop support as well?
Comment 7 Matthias Versen [:Matti] 2010-09-15 23:48:55 PDT
We depend on Gecko and it's Gecko that drops PPC support....
Comment 8 ChrisX 2010-09-19 05:51:19 PDT
Very unfortunate. This means that PPC users will stay at FF 3.6 resp. SM 2.0x forever and eventually switch to Safari 5 if JS execution once again becomes too slow.
Comment 9 Philip Chee 2010-09-28 05:57:18 PDT
Probably fixed by now but we won't know since we don't have PPC build coverage at the moment.

Note You need to log in before you can comment on or make changes to this bug.