Status

()

defect
RESOLVED DUPLICATE of bug 574976
9 years ago
3 years ago

People

(Reporter: graydon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments)

Reporter

Description

9 years ago
Updated to nightly 20100816 Minefield/4.0b4pre and suddenly the text is irritatingly blurry. Setting mozilla.widget.render-mode to 0 fixes it.

This is an IBM x61s thinkpad, totally mainstream unit, x64 win7. Graphics adaptor is mobile intel GMA X3100, in the 965 express chipset.

I tried disabling anisotropic filtering within the driver control panel, as suggested in bug 549419, to no avail. Same blur.
Reporter

Comment 1

9 years ago
What does it look like in IE9?
(In reply to comment #2)
> Created attachment 466572 [details]
> sharp text with render-mode set to 0

I'd say that text looks really really bad compared to your first screenshot. I think we might be running into a matter of taste here :).
Graydon, could you write up a simple testcase that mimics the text you think looks fuzzy?  Does it render the same way in IE9 dev preview?

Also, do you disable Cleartype explicitly (it's on by default in Windows 7)?  The "sharp text" rendering looks like Cleartype is completely disabled.
Reporter

Comment 6

9 years ago
(In reply to comment #4)
> (In reply to comment #2)
> > Created attachment 466572 [details] [details]
> > sharp text with render-mode set to 0
> 
> I'd say that text looks really really bad compared to your first screenshot. I
> think we might be running into a matter of taste here :).

If it's a "matter of taste", and I have to twiddle some rendermode to disable it in the future -- if the blurring is "intentional" -- that's ... tolerable, I guess you should close this bug. But please, please don't force this look permanently. I have a display with pixels still big enough to see (96dpi or so?) and the fonts are all lovingly hand-hinted to this pixel grid. Why demolish all that work with a blanket AA-smudge pass?

I find it hard to believe that users would actually prefer this as a default setting on startup. If I didn't know about about:config and my trusty mozilla IRC channels to ask how to turn it off, I'd have uninstalled the browser right away (as I did safari-on-win32). Forcing AA text is like ... blaring show tunes constantly. I'm nearsighted; this makes me think I need new glasses every time I switch windows. Are we sure users actually prefer this, in the majority case?

(In reply to comment #5)
> Graydon, could you write up a simple testcase that mimics the text you think
> looks fuzzy?  Does it render the same way in IE9 dev preview?

I will check IE9 later tonight; haven't installed it yet, and need to get to office presently.

> Also, do you disable Cleartype explicitly (it's on by default in Windows 7)? 
> The "sharp text" rendering looks like Cleartype is completely disabled.

Of course I manually disable it. Cleartype makes text blurry. It's almost as bad as that OSX does.
Reporter

Comment 7

9 years ago
(In reply to comment #5)
> Graydon, could you write up a simple testcase that mimics the text you think
> looks fuzzy? 

Oh, also, wrt testcases: it's everything. All text. Chrome, content, menus, text input, output, whatever. The entire display mode goes AA.
This is a testcase that shows all fonts installed on my system. I'll attach screenshots of them comparing IE8, with ClearType turned off, Firefox 3.6.8 and current trunk build with d2d enabled.
Posted file screenshots
This shows a screenshot of all the 3 earlier mentioned browsers, for comparison.
When I look at the Arial font, it seems indeed that Minefield trunk with d2d enabled shows a little bit more blurrier font than IE8 with ClearType disabled or Firefox3.6.8.
In case somebody else want to test all their fonts installed on their system.
Graydon, do you have Cleartype enabled or not?
Reporter

Comment 12

9 years ago
(In reply to comment #11)
> Graydon, do you have Cleartype enabled or not?

Disabled. I thought I was clear about that in comment #6. I always manually disable cleartype and every other form of AA text, on every system I use.

I never want it. AA text == blurry text. The point of this bug is that when d2d is turned on, firefox behaves as though I want AA text. Which I don't, and I appear to have to turn d2d off to get rid of it. Is this so? Can't I have d2d with non-AA text?

If firefox is migrating to a world where it only has AA-text mode, I'd be ... very sad. And I'm slightly curious to know if anyone's studied whether users actually *like* AA text. It looks uniformly smudgy to me.
(In reply to comment #12)
> I never want it. AA text == blurry text. The point of this bug is that when d2d
> is turned on, firefox behaves as though I want AA text. Which I don't, and I
> appear to have to turn d2d off to get rid of it. Is this so? Can't I have d2d
> with non-AA text?

We should, and I believe can, respect the users preference here.

> If firefox is migrating to a world where it only has AA-text mode, I'd be ...
> very sad. And I'm slightly curious to know if anyone's studied whether users
> actually *like* AA text. It looks uniformly smudgy to me.

I've seen a couple of studies. This is the first one that came up:
"Visual Search and Reading Tasks Using ClearType and Regular Displays: Two Experiments". I've not read any of them in detail and so I'm not sure how good the studies are, but I've never seen any research that would suggest that AA-text is worse.
(In reply to comment #12)
> (In reply to comment #11)
> > Graydon, do you have Cleartype enabled or not?
> 
> Disabled. I thought I was clear about that in comment #6. I always manually
> disable cleartype and every other form of AA text, on every system I use.

Ah, right, I'm blind.  So then the bug here is that the DirectWrite backend doesn't respect the system Cleartype setting, which it should, at least for platform fonts.  That makes this a dupe of bug 574976.

If I've missed something, feel free to reopen.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 574976

Comment 15

9 years ago
This is terrible, updated to latest release of minefield and the text is so blurry it makes my eyes water trying to focus.

Here is a screenshot of IE8 compared to Mozilla Minefield. IE8 on the left

http://a.imageshack.us/img690/4227/blurry.png
(In reply to comment #15)
> http://a.imageshack.us/img690/4227/blurry.png

That does indeed look much worse. I can't reproduce the blurriness here, can you compare to IE9?

Comment 17

9 years ago
I just installed latest nightly on my Windows XP box at work, and the test looks fine. I checked mozilla.widget.render-mode, and it was set to -1. I changed it to 1 but no change.
I'm assuming this is because Direct2D only works in Vista/7, not in XP.
What OS are you using?
AluminumHaste, do you still get the fuzziness/blurriness if you apply this hotfix from Microsoft: http://support.microsoft.com/?kbid=2028560
I crash on startup with D2D enabled with that hotfix installed (window appears and then just closes). I do my own builds, so no crash report.
(In reply to comment #20)
> I crash on startup with D2D enabled with that hotfix installed (window appears
> and then just closes). I do my own builds, so no crash report.

Did you mean to comment on this bug?  Seems like this belongs in a new bug report or some other existing bug.

Comment 22

9 years ago
Okay downloaded the latest nightly, running with D2D turned on no longer has text all blurry, but the top of the window is graphically corrupted now.

http://a.imageshack.us/img716/1059/corrupt.png

Comment 23

9 years ago
Screenshot comparing FF 4 with D2D turned on (TOP) and turned off (Bottom)

Updated

9 years ago
Attachment #470078 - Attachment description: GUI corruption with D2D turned on, top of image, D2D turned off, buttom window. → GUI corruption with D2D turned on, top of image, D2D turned off, bottom window.
You need to log in before you can comment on or make changes to this bug.