Make clickable output in the WebConsole keyboard accessible

RESOLVED FIXED in Firefox 26

Status

defect
P3
normal
RESOLVED FIXED
9 years ago
Last year

People

(Reporter: julian.viereck, Assigned: msucan)

Tracking

({access})

Trunk
Firefox 26
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [console-2][console-output][fixed by bug 760876])

This is a followup bug for bug 573102 Comment 94.

Some output in the WebConsole is inspectable - when the user clicks on it, a panel pops up (e.g. PropertyPanel or NetworkPanel). This clickable output should be keyboard accessible.

Gavin mention in comment 94, bug 573102:

> This should probably actually be keyboard accessible (i.e. tabbable and
> responsive to "Enter"). I don't think onclick on xul:labels handles that.
> Followup bug?
Whiteboard: [kd4b6]
Blocks: console-a11y
No longer blocks: 529086
Assignee: nobody → jviereck
Assignee: jviereck → nobody
Whiteboard: [kd4b6]
Whiteboard: [console-2]
Component: Developer Tools → Developer Tools: Console
Keywords: access
Summary: Make clickable output in the WebConsole keyboard accessable → Make clickable output in the WebConsole keyboard accessible
Hah, I didn't know we have this bug!

Yesterday I marked a TODO to report a bug about tabbing through the web console - which is broken. One can't properly keyboard-navigate through the items.

Some of the work here depends on bug 778766.
Depends on: console-output
Whiteboard: [console-2] → [console-2][console-output]
Priority: -- → P3
This bug should be fixed by bug 760876. You can now tab to any link and press Enter to perform its action. We have also added keyboard shortcuts for common operations and access keys to toolbar items in other bugs.

Please file separate bugs, if needed. Thank you!
Assignee: nobody → mihai.sucan
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [console-2][console-output] → [console-2][console-output][fixed by bug 760876]
Target Milestone: --- → Firefox 26
Duplicate of this bug: 812611
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.