Closed Bug 589465 Opened 9 years ago Closed 7 years ago

Add click-down gesture for quickly switching to other tab groups

Categories

(Firefox Graveyard :: Panorama, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: ashughes, Unassigned)

References

Details

This could probably be split into 2 separate bugs but they achieve the same desired effect.  I would like the ability to quickly switch between tab groupings (ie. don't make me enter the tab candy view if I just want to hot-swap).  Basically, this breaks down to two things I would like to see:

1. Hold down left click -> drops down a list of tab groupings (similar to the forward/back button functionality)
2. Keyboard shortcut -> jumps to the next tab grouping (similar to CTRL+Tab for tabs)
keyboard shortcut (ctrl + ` and ctrl + shift + `) is already on trunk.
(In reply to comment #1)
> keyboard shortcut (ctrl + ` and ctrl + shift + `) is already on trunk.

This is used to switch between windows.  Are you proposing that tab-groups get treated as windows in this scenario? or are you suggesting this shortcut already works for tab-groups (because it doesn't on my end).  Could you please elaborate? Thanks.
are you thinking of cmd + `?
Oh, ok.  I see now.  CMD+` is switching windows and CTRL+` is switching tab groups already.  CTRL+` was not working immediately.  I pressed it at least 5 times before it started switching tabgroups.

So this address point #2.  Can we use this bug for point #1?
Anthony, I'm changing the bug title to reflect your #1. If I didn't do a good job changing the title, please go ahead and change it again.

In other news, punting to the future. This would also be a good place for an add-on to step in.
Summary: Add functionality to quickly switch between tab groups → Add click-down gesture for quickly switching to other tab groups
Target Milestone: --- → Future
how about right click on the panorama button.

see also:
https://addons.mozilla.org/en-US/firefox/addon/tab-group-switcher/
(In reply to comment #6)
> how about right click on the panorama button.
> 
> see also:
> https://addons.mozilla.org/en-US/firefox/addon/tab-group-switcher/

Yeah, I think we should implement the same behavior like the forward/back buttons. So on "right click" and on "left click and holding down" we should display a popup menu just like the add-on does.
Blocks: 653099
Before doing this we should figure it whether we'd rather want to implement bug 596017.
Duplicate of this bug: 658853
bugspam
No longer blocks: 653099
bugspam

(Fx7 was branched, removing open bugs from Fx7 meta bug, we won't create new meta bugs for upcoming Fx versions)
No longer blocks: 660175
This functionality can certainly be provided by an add-on so I don't think we want to have this as a core feature.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.