Feature Suggestion: Faster switching between tab groups.

RESOLVED DUPLICATE of bug 589465

Status

--
enhancement
RESOLVED DUPLICATE of bug 589465
8 years ago
3 years ago

People

(Reporter: frank, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

Switching between Tabgroups via the Panorama View is a slow action. It would be nice to switch faster. If I could have quick access to the names of my tab groups, this would be helpful.

Idea: Add the tab group (names) to the tab pulldown in the tab bar. In my opinion, this could be on the first (top) positions of this pulldown, followed by the panorama item and then the tabs (I mean most of the time, I habe a one klick way to go to the tab of my choice, whatfor the pulldown anyway).

Alternative idea 1: Add a pull down possibility to the Panorama Icon in the tab bar. List the tab groups there for faster selection.

Alternative idea 2: Let there appear a pseudotab per tag group in the tab bar which actually switch to the last seen tab of the specified tab group. Pseudotabs should look different (by colour, stile or border) for easy spotting. Even an "app tab group" (pinned on the left hand side) could make sense in this setting.

Reproducible: Always
Component: Tabbed Browser → Panorama
QA Contact: tabbed.browser → panorama
(In reply to comment #0)
> Idea: Add the tab group (names) to the tab pulldown in the tab bar. In my
> opinion, this could be on the first (top) positions of this pulldown,
> followed by the panorama item and then the tabs (I mean most of the time, I
> habe a one klick way to go to the tab of my choice, whatfor the pulldown
> anyway).

That's a duplicate of bug 589465.

> Alternative idea 1: Add a pull down possibility to the Panorama Icon in the
> tab bar. List the tab groups there for faster selection.

This is a dupe of bug 596017.

> Alternative idea 2: Let there appear a pseudotab per tag group in the tab
> bar which actually switch to the last seen tab of the specified tab group.
> Pseudotabs should look different (by colour, stile or border) for easy
> spotting. Even an "app tab group" (pinned on the left hand side) could make
> sense in this setting.

I don't think we would implement this. This could be a good place for an add-on to step in and try this out.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 589465
(Reporter)

Comment 2

8 years ago
Thanks Tim! I am sorry, I didn't spot the dupes, but I did some search.
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.