Closed Bug 590448 Opened 10 years ago Closed 1 year ago

Add context menu to about:sessionrestore items

Categories

(Firefox :: Session Restore, enhancement)

enhancement
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: the.assimilator, Unassigned)

References

(Blocks 3 open bugs)

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4) Gecko/20100818 Firefox/4.0b4
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4) Gecko/20100818 Firefox/4.0b4

I love the Restore Session feature, but would love it even more if it could be tweaked a little as follows:

Say for example I have 20 tabs open in Firefox, but am only interested in 5 of them. Firefox is terminated abnormally (for example, when I restart to apply Windows Updates and Explorer kills Firefox because it's popped up the "Save session?" dialog). When I reopen Firefox, it correctly shows the "Restore Session" tab with all the windows/tabs I had open.

I want to continue browsing on the last page I was at, *without opening all the other saved windows/tabs*. I can do that by ticking only the appropriate page in Restore Session, and clicking the "Restore" button, but then I will lose all the other windows/tabs I was browsing, as Restore Session then closes.

So what I'm basically asking for is a way to selectively restore windows/tabs *without having Restore Session go away afterwards*. IMO the easiest way to do this would be allow right-clicking on tabs (not windows, for obvious reasons) in Restore Session, and then popup the same context menu that appears when you right-click a hyperlink in a web page.

Reproducible: Didn't try
Component: General → Session Restore
Summary: Ability to restore windows/tabs without closing "Restore Session" tab → Ability to restore tabs without closing "Restore Session" tab
QA Contact: general → session.restore
You can already double click on each item to restore that single tab into a new tab, so turning this into a bug specifically about context menus.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
Summary: Ability to restore tabs without closing "Restore Session" tab → Add context menu to about:sessionrestore items
Version: unspecified → Trunk
Blocks: 591957
Duplicate of this bug: 666141
Duplicate of this bug: 1105220
Blocks: 684548

At this point it's highly unlikely that this will get implemented any time soon. Resources are very scarce.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.