Closed Bug 591935 Opened 9 years ago Closed 4 years ago

ctrl+(shift+)+` for switching between groups is not good for some locales

Categories

(Firefox Graveyard :: Panorama, defect, P4)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: dietrich, Unassigned)

References

Details

from peregrino on IRC: "for instance, in spanish you have to press twice the key in the place of "[" to produce a "`" so no way to use it as a hotkey"
Yes, as OSX also uses that character to change group windows, maybe it would be wise to look at what OSX does when is installed on machines with different keyboard layouts.
on the german keyboard layout you can only type "`" by pressing shift + "´", therefore ctrl+` becomes ctrl+shift+´, making it impossible to iterate backwards, not to mention that it requires two hands.
Priority: -- → P4
Target Milestone: --- → Future
See http://en.wikipedia.org/wiki/Keyboard_layout

Just from a glance at the list, this affects italian, french, german, swiss, japanese and probably a few other layouts.

We need a better keymapping for this. I suggest Ctrl+B, it does nothing right now, is easy to reach and would be available on all latin-based keyboards.
This is duplicate of this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=643838

Which means czech also has the very same problem.

I was trying to change the hotkay somehow but was unable to do so. Couldn't find it in about:config. Which mean i suggest to make it CONFIGURABLE!
Duplicate of this bug: 643838
The bug also affects the brazilian portuguese keyboard. I vote for a new shortcut. Just leaving it as configurable would make life harder (!) since you would have to personalize every FF installation you use.
We've got 3 main points that I can see with command keys. 1. Our command keys don't work in all locales or for all users (next/prev group, enter/exit panorama, etc) 2. Making them configurable would place a burden on users to customize every instal (can Sync help ameliorate that?) 3. It is impossible to find a command key that doesn't change some existing functionality in some locale.

In the past our strategy was to make the command key the least bad of all available options, but have it be the same across all localizations, should we reconsider that for this issue?

cc-ing faaborg.
Everyone please just realize one thing. Now it's not even possible to configure it via "Customizable shortcuts" extension (https://addons.mozilla.org/en-US/firefox/addon/customizable-shortcuts/) which is the worst thing about this. While making it configurable is clearly not the best and final solution, it's still far better then current state. So please make it at least configurable via the addon for now and change the default behaviour later.
(In reply to comment #8)
> Everyone please just realize one thing. Now it's not even possible to configure
> it via "Customizable shortcuts" extension
> (https://addons.mozilla.org/en-US/firefox/addon/customizable-shortcuts/) which
> is the worst thing about this. While making it configurable is clearly not the
> best and final solution, it's still far better then current state. So please
> make it at least configurable via the addon for now and change the default
> behaviour later.

It's customizable. I added a workaround for this in version 0.5.5 :) See also bug 645371.
WOW! Thanks. :) I had old 0.4.1 version until now. Sadly autoupdate doesn't work for this addon. I suppose it's because the addon is experimental.
Alex, any idea how to solve this?
Blocks: 653099
sometimes locals remap certain keyboard shortcuts as part of the localization process. Otherwise we need to find something that isn't already in use, and works across a range of keyboards.  It's usually a bit of a hard problem as testers write in to tell us why their locale doesn't work.
Blocks: 626594
bugspam
No longer blocks: 653099
bugspam

(Fx7 was branched, removing open bugs from Fx7 meta bug, we won't create new meta bugs for upcoming Fx versions)
No longer blocks: 660175
Any news on this? Would like to get this moving, as it's mainly deciding which keys to use.

On a related note, I tried this with OSX and a en-US keyboard. If I changed the layout of the keyboard (I tried Spanish and Japanese) no matter what layout I was using the combination was the same ctrl+<key-above-tab> and worked.
That didn't happen on linux, there it worked only if the layout was en-US.
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.