Closed Bug 626594 Opened 9 years ago Closed 2 years ago

shortcut for switching tab groups is badly accessible on many non-US keyboard layouts

Categories

(Firefox :: Keyboard Navigation, defect, P4)

x86
Windows XP
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: kuno.meyer, Unassigned)

References

Details

(Keywords: access)

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

On most non-US keyboard layouts, CTRL+` is almost inaccessible, since the location of [`] is completely different from the US layout. (See [1], look for example at "German" or "Spanish" or "French", just to mention some large user groups.) On some layouts, you even need to press SHIFT to reach [`]. On some layouts and operating systems, [`] has a delayed behavior ([`] and [a] results in [à])

Therefore, I think (and if it is feasible), the shortcut for switching tab groups should be defined by physical location on the keyboard, not by character.

[1] http://en.wikipedia.org/wiki/Keyboard_layout

Reproducible: Always
Version: unspecified → Trunk
I can confirm this bug (but don't know how to do this in bugzilla though).

I have a danish keyboard on Linux on FF 4.0. To achieve a ` char I have to hit these keys: shift + "`'|"key + space. By the "`'|"key, I mean the key that has all three of `, ' and | painted on it. If I don't hit the last space, it will be waiting to see if I hit a vowel next so it knows whether to output e.g. an à or the `. Typing that same sequence while holding down CTRL does not change tab groups.

Changing the layout to US and it does work for me.
That's odd Peter. It works on my Danish keyboard??
Ctrl+shift and the key left of backspace.
But please note the group-shift is NOT cyclic (bug?). So when the last group is reached you can not switch further
Sorry, silly me.

Ctrl+shift [`] gives the shift in ONE direction, at that works for both US and DK keyboard

Ctrl [`] gives the other direction, and does NOT work with Danish keyboard.

...And the strange thing is that the NON-cyclic behaviour seems to have vanishes after I tried with the US-layout. Strange...
Seems like two bugs here. I think fixing the non-cyclic behavior will be fairly easy, not sure about the key combo.
Blocks: 603789
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P4
No longer blocks: 603789
Depends on: 591935
bugspam
No longer blocks: 653099
bugspam

(Fx7 was branched, removing open bugs from Fx7 meta bug, we won't create new meta bugs for upcoming Fx versions)
No longer blocks: 660175
Keywords: access
Any news on this? Would like to get this moving, as it's mainly deciding which keys to use.
(In reply to Hernán Rodriguez Colmeiro (:peregrino) from comment #8)
> Any news on this? Would like to get this moving, as it's mainly deciding
> which keys to use.

That comment goes to bug 591935.

---

What I meant to ask here was if the part of non-cycling behavior is still happening. I cannot reproduce it with Nightly 15.0a1 (2012-05-22).
Duplicate of this bug: 943315
The Tab Groups feature has been removed.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.