Missing Thunderbird 3.1.3 release notes linked from update dialog box

RESOLVED DUPLICATE of bug 584679

Status

Thunderbird
General
--
major
RESOLVED DUPLICATE of bug 584679
8 years ago
8 years ago

People

(Reporter: Brion Vibber, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b4) Gecko/20100818 Firefox/4.0b4
Build Identifier: 

Thunderbird offered me an update to 3.1.3 today; the update dialog included a "details" link, which normally takes you to the release notes so you know what you're about to install.

This link currently is a 404 error:
http://www.mozillamessaging.com/en-US/thunderbird/3.1.3/releasenotes/


Reproducible: Always

Steps to Reproduce:
1. Go to 'Apply downloaded update' in Thunderbird
2. Click 'Details' link
3. Browser opens http://www.mozillamessaging.com/en-US/thunderbird/3.1.3/releasenotes/
Actual Results:  
http://www.mozillamessaging.com/en-US/thunderbird/3.1.3/releasenotes/ gives a 404 error.

Expected Results:  
http://www.mozillamessaging.com/en-US/thunderbird/3.1.3/releasenotes/ should contain release notes.
(Reporter)

Comment 1

8 years ago
Note that the welcome screen *after* updating has a different release notes URL, which does work:

http://www.mozillamessaging.com/en-US/thunderbird/3.1.xrc/releasenotes/

Particularly when being offered early beta updates, a working notes link *before* updating would be very much appreciated. :)

Comment 2

8 years ago
from IRC

"if the release notes link worked, then i'd know it was a beta release
Aleksej: do you know if the release notes URL in the update dialog is included with the update info from the server, or if it's generated by the currently-installed Thunderbird from the given future version number?
brion_: don't know…
I usually don't use application updates.
I mean, I usually don't give them write permissions."

Comment 3

8 years ago
(In reply to comment #2)

To be clear, in that quote, Brion’s messages are:

> "if the release notes link worked, then i'd know it was a beta release
> Aleksej: do you know if the release notes URL in the update dialog is included
> with the update info from the server, or if it's generated by the
> currently-installed Thunderbird from the given future version number?
This is a duplicate of bug 584679 which I missed getting resolved for 3.1.3, I'll get it on the radar for the next version though.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 584679
You need to log in before you can comment on or make changes to this bug.